I cannot install 12.2 because splash screen (plymouth) flashes and freeze

I updated my 12.1 to 12.2 but when it boots, the plymouth flashes and the boot freeze at that point.
I tried live USB and it does the same. I tried to boot with splash=verbose but I got the same results. There wasn’t splash screen but there was the cursor on the top left side corner.

Then I tried with No KMS and something with the graphics (I pressed the F keys) and I managed to reinstall it. When it booted for the first time, it started again to flash the screen.

I tried Mint, Ubuntu, Fedora and all of them had the same problem.

Now I installd 12.1 and it boots OK.

How can I install 12.2 and start properly?
I don’t care to have plymouth-splash screen. I want to have the system running.

I had the exact same issue and ended up disabling splash and uninstalling the plymouth packages or *mask *them during startup.

Can you change it to “splash=0” and then if the plymouth start screen comes up, press the “Esc” key on your keyboard quickly to drop back to the text readout. See if it boots into the desktop normally.