I cannot get the GUI/Plasma to work (was working)

Ok I have been searching the forums trying to find a similar issue and have not been able to find the answer to my situation.

I was going to try a different plasma desktop downloaded the file and let yast2 do the work. Afterwards I did some messing around with the desktop. Sadly I realized I was in root when I did this instead of doing it through the cli as su.

I can only boot to the cli, so I had to take a crash course on linux cli. I learned more in the last 36 hours then I thought I could learn in a week, but not enough to fix my issue.

I cannot figure out how to run the restore I did see a folder when I was investigating the OS (first experience with this OS)

I then tried to use zypper to verify and it indicates I am up to date. NO PKGS needed.

I tried zypper info kde4 It replied NO PKG FOUND, even though I can clearly see the file when checking out all the directories I can find. I cannot however find the rm for this to reinstall the kde4 platform with plasma.

Before rebooting into winders I searched the root and found the boot folder, I looked under grub and found something that may help me but I am not sure if I should do it. The following is what I found (Yes I was logged in under my alter ego no just my other user name and switched to su before I did anything that would kill the system even more)

default device.map.old device.map e2fs_stage1_5fat_stage1_5 ffs_stage1_5 iso9660_stage1_5 jfs_stage1_5 menu.lst menu.lst.old minix_stage1_5 reiserfs_stage1_5 ufs2_stage1_5 xfs_stage1_5
My question is if I change the device.map to device.map.OLDER and menu.lst to menu.lst.OLDER and then rename the device.map.old to device.map and well you get the idea, would this possible fix the issue I am having?