i can' t connect to network

victor@linux-debn:~> dmesg | grep firmware
8.769511] prism2_usb: Checking for firmware prism2_ru.hex
8.769520] usb 3-1: firmware: requesting prism2_ru.hex

victor@linux-debn:~> sudo /usr/sbin/iwlist scan
Contraseña:
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:21:91:4D:C8:DC
ESSID:“Gaspar reloaded”
Mode:Master
Encryption key:on
Channel:1
Quality:80/100 Signal level:-60 dBm Noise level:-92 dBm

In a terminal, post result of this

/sbin/lspci -nnk

Erm

 8.769511] prism2_**usb**: Checking for firmware prism2_ru.hex

But instead of only asking one command after the other:

Getting Your Wireless to Work - openSUSE Forums

=> 3rd post, script linked there (read instructions carefully)

well, i do it. First i am connecting with wpa-psk,
i have only ifup and knetwork manager down, and i have nothing working to use the the daemon wpa_supplicant.
well some idea, thanks a lot.
linux-debn:/home/victor # killall wpa_supplicant
linux-debn:/home/victor # wpa_supplicant -D hostap -iwlan0 -c/etc/my_config_file -d
Initializing interface ‘wlan0’ conf ‘/etc/my_config_file’ driver ‘hostap’ ctrl_interface ‘N/A’ bridge ‘N/A’
Configuration file ‘/etc/my_config_file’ -> ‘/etc/my_config_file’
Reading configuration file ‘/etc/my_config_file’
ctrl_interface=’/var/run/wpa_supplicant’
ctrl_interface_group=‘0’
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 5
id=0 ssid=‘Gaspar reloaded’
Initializing interface (2) ‘wlan0’
ioctl[SIOCGIFFLAGS]: No such device
Could not get interface ‘wlan0’ flags
ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
Could not configure driver to use managed mode
ioctl[SIOCGIWRANGE]: No such device
WEXT: Operstate: linkmode=1, operstate=5
ioctl[SIOCGIFINDEX]: No such device
Failed to add interface wlan0
State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Failed to set encryption.
wpa_driver_hostap_set_wpa: enabled=0
ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
Failed to disable WPA in the driver.
wpa_driver_hostap_set_drop_unencrypted: enabled=0
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
wpa_driver_hostap_set_countermeasures: enabled=0
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: No such device
No keys have been configured - skip key clearing

bueno y me gustaria saber porque me pide algo de ioctl.
gracias

… which was (and I am quite sure still is) not supported by this rather old legacy driver.

I would invest in newer hardware, USB WiFi dongles are not too expensive and your device must be very old.

P.S.

If at all supported (I doubt it) then wext, hostap could be used (IIRC) for some PCI/CPMCIA devices but never for the prismII USB cards.

well, i achieve connect to internet simply using wep but how is that so simply to break out i use control access by mac

thanks

On 04/24/2010 07:36 PM, victorhugo7 wrote:
>
> well, i achieve connect to internet simply using wep but how is that so
> simply to break out i use control access by mac

MAC filtering is not much better than ordinary WEP. You should spend the
$10 to buy a Netgear WG111V2 such as at
http://cgi.ebay.com/NETGEAR-WIRELESS-NETWORK-USB-ADAPTER-WG111v2-MSRP-49-99-/310215076794?cmd=ViewItem&pt=LH_DefaultDomain_0&hash=item483a426bba.
That device dies not need any external firmware, and the driver is
really stable. I helped write it. :wink: