I can see AP's, but can't connect..

Hello there,

I have a wireless PCMCIA card, Belkin Pre-N F5D8010. I am using the Ndiswrapper that Yast2 installs and I made sure to do a uname -r to install the correct Ndiswrapper files.

As per the forum sticky, here is my information:

lspci output


03:00.0 Ethernet controller: Airgo Networks Inc AGN100 802.11 a/b/g True MIMO Wireless Card (rev 01)

lspci -n output


03:00.0 0200: 17cb:0001 (rev 01)

dmesg output


ndiswrapper: driver netani (Airgo Networks, Inc.,06/30/2005, 1.5.0.147) loaded
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
ndiswrapper: using IRQ 17
wlan0: ethernet device 00:11:50:2d:22:53 using NDIS driver: netani, version: 0x1050093, NDIS version: 0x501, vendor: 'Airgo Networks True MIMO (tm) Wireless Adapter', 17CB:0001.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
ADDRCONF(NETDEV_UP): wlan0: link is not ready

iwconfig output


linux-bzyi:/home/necromatic # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Bit Rate:108 Mb/s
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

iwlist scan output


linux-bzyi:/home/necromatic # iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:1A:70:FA:29:D8
                    ESSID:"gtfo"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:100/100  Signal level:-18 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

ndiswrapper output


linux-bzyi:/home/necromatic # ndiswrapper -l
lsbcmnds : driver installed
netani : driver installed
        device (17CB:0001) present

This is as far as I’ve gotten to get the card to work. I’ve tried to take off the wireless security and did a dhclient but my card will not associate with the AP. I can manually enter all the information in, such as the iwconfig wlan0 essid gtfo etc etc, but that still doesn’t work either. Anybody have another step that I can take?

Much appreciated in advance.

Addendum:

NetworkManager will not show any AP / connections for wlan0. I’m using KDE as my desktop environment.

uname -a output


linux-bzyi:/home/necromatic # uname -a
Linux linux-bzyi 2.6.25.18-0.2-pae #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux

ndiswrapper -v output


linux-bzyi:/home/necromatic # ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename:       /lib/modules/2.6.25.18-0.2-pae/updates/ndiswrapper.ko
version:        1.52
vermagic:       2.6.25.18-0.2-pae SMP mod_unload 586

Thanks again.

Dwayne

As your system is seeing networks in the scan, I think all you need to
do is launch the applet and create a network.

You know what, I didn’t even think about doing the “New Connection” deal, I just figured that NetworkManager would have shown me the listing of AP’s in the area. Well needless to say, I’m connected via wireless :stuck_out_tongue:

Thanks Larry