I broke KDE :-(

Hey all!

1st post, so be gentle!

Been using 10.3 for a while now on my laptop, and installed 11.1 on my desktop last night.

Installation went well, but I managed to break my shiny new KDE4 desktop within a couple of minutes >:(

I right clicked on the desktop, and looked at the add widgets window, I added a few, and removed a few, and then the system fell over. I think it happened after I removed the system tray.

Now the system runs really slow. Like taking over a minute to respond to a mouse click, nothing on the taskbar seems to work, except for the start menu.

What have I done?!

I tried a repair install - no luck
I tried what I thought was a fresh install, and the problem is still there! :’(

Bit annoyed that it all broke down so easily!

What can I do to make it good again?

Thanks for your thoughts peeps!


Try creating a new user and logging on to see if kde works. If it does, delete your old home directory or, if you have data in it, delete all the .kde files in your home directory.

Actually, that’s exactly what I’m just trying :slight_smile:

After I finally got Yast to load, the system runs fine. Seems like the desktop, taskbar, and start menu are all on a go slow, but everything else is ok.

They’re all part of Plasma as I understand it?

Just logging into my newly created user now…


Thanks for the tip there whych.

Using a new user is working fine - I’ll try not to mess this one up! :shame:

Quite surprised at how easy I angered the beast tho! :open_mouth:


Instead of having two user, simply rename your old user’s .kde4 directory to .kde4old and log back again. :wink:

Thanks, I found that trick during the search, but couldn’t do it as the user area was uselessly slow.

Can I change the orriginal users KDE directory name from the new user?

At work at the moment so I can’t try it till tomorrow.


Yes, but you need to do it with su - superuser. Open Konsole and type


Then go to the original users directory with

cd /home/<userName>

Rename the .kde4 directory to .kde4old, and leave the superuser mode:

mw .kde4 .kde4old

Now log in with your original user.
Good luck.