I borked my USB stick

I need a bit of help, I decided to use my 16gb usb drive as a boot stick for a new opensuse install by doing what the doc said to do i.e. “dd if=USBdrive of=ISO bs=4M” which worked great and all, but now I want the drive to do something else besides act like a cd with openSUSE on it. I can’t figure out how to delete or write anything to it, because it’s now read-only. Remounting hasn’t worked but it’s possible i’m not understanind how the mount command works, but I have tried “mount -rw /USB /MOUNTPLACE” and also with a couple of different filesystem types like usbfs & vfat. Any help would really be appreciated.

tl;dr Make my usb drive read/writeable again, not just read!

Just format it back to FAT32
If you don’t have winders to do it
Use a Parted Magic live cd

Well I guess that was my question, was how to format it back to what it previously was (FAT32, I suppose), but I need an external program to do that?

Just make sure it’s unmounted and use the partition manager under YaST to format it for the FAT filesystem. (Hmm, haven’t checked if FAT is supported by YaST, but if it isn’t, you can also do it from the command line. No need to reboot to any other OS or LiveCD to do this.)

I didn’t check Yast, but felt sure it wasn’t, which is why I suggested Parted Magic.
I could be wrong though.
The device must not be mounted either, as already stated.

Ah, thank y’all very much, YaST supports FAT and it works fine now. Thanks again