I boogered up my Suse : Won't start X

In the wake of installing Gnome-shell on top of Opensuse 12.3 KDE, I have somehow rendered the OS incapable of starting X. When I log in, I just get an arrow, no desktop.
When I hit control-Alt-F1 and log in as my primary user, I tried to “startx” and go the messages:

hostname:  Name or service not known.
xauth:   file /home/suse/.serverauth.1088 does not exist

Fatal server error:
Cannot move old log file "'var/log/Xorg.1.log" to "/var/log/Xorg.1.log.old"

(EE)
Please consult the X.Org Foundation support at http://wiki.x.org for help.
(EE)

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
--------------------------------------------------------------------
xinit failed.   /usr/bin/Xorg is not setuid , maybe that's the reason?
If so, edither use a display manager (strongly recommended) or adjust /etc/permissions.local

If I try to startx as root, it works great. So I think it’s something hosed in my user account.
Could Gnome-shell have stomped on something in a bad way?

In any case, I would appreciate any pointers on how to debug and fix

Many thanks,
Chris

On Fri, 31 May 2013 04:16:02 +0000, cristobalgriffin wrote:

> If I try to startx as root, it works great. So I think it’s something
> hosed in my user account.

startx is deprecated and no longer works for normal users. That’s
intentional.

When you’ve logged in through gdm/kdm and you have nothing on the screen,
switch to vt1 and run “ps ax | grep gnome-shell” and report back what the
output is.

That’ll tell us if gnome-shell is running or not, which is a starting
place.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

LIke I already wrote in the other thread on your attempts to install GNOME alongside KDE: install the GNOME patterns. From what I saw you now have installed gnome-shell, but I doubt that pulls in everything you need to run GNOME3.
In KDE start the Software installer, select View - Patterns, and check GNOME base pattern + GNOME desktop environment for install. That will pull in everything.

Furthermore I’d like to see output of


zypper lr -d

EDIT: sorry, missed that X won’t start at all. Then login on the console with your username and password, do


su -c yast

You’ll see the ncurses version of Yast. Go Software - Software management, search for “patterns” and install (at least) the gnome-base pattern.

Can you still login to KDE?

Are you using the proprietary NVIDIA driver?
Then see here: openSUSE 12.3 Release Notes
Especially GNOME fails to start if your user is not allowed to access /dev/nvidia*… (with KDE it may still work despite that)

On 2013-05-31, wolfi323 <wolfi323@no-mx.forums.opensuse.org> wrote:
> Especially GNOME fails to start if your user is not allowed to access
> /dev/nvidia*… (with KDE it may still work despite that)

My experience with KDE is similar - users not allowed access to /dev/nvidia* won’t be able to login (at least this was
the case at the beginning of this week).

Yes there were a few cases here recently, but I guess this depends on the settings (or maybe its because of some package update)…

I know of users which were able to login to KDE over a month ago although access to /dev/nvidia* was not allowed, but GNOME seemed to be more picky back then (i.e. it wouldn’t work in any case).

Anyway, the OP should check this in any case.

On the NVIDIA issue: if the driver is installed properly, and the system complains about not being able to deal with /dev/nvidia*, add yourself to the “video” group.

Thanks Jim! What is the way a normal user would start the desktop?
I am on the right track to getting this straightened out thanks to Knurpht…
Chris

type init 5 as root ie

sudo init 5

would work.

startx no longer works as before but can be made to by changing the permission bits