"I am unable to access repositories, as well as this website and some other websites at random."

Hello there,

For the past two days, I have been experiencing some unusual behavior from my network. I am unable to refresh repositories, update the system or update the list as it keeps returning a message indicating that the links cannot be reached. Furthermore, some websites are not loading on my browser, but they load normally when I use a proxy. I have tried to access the same websites on my mobile device using the Android system over Wi-Fi, but I still get the same results. However, when I turn off the Wi-Fi and switch to the mobile data network, the websites load properly, although I have not tested all websites.

After loading the website using the mobile data network, I turned off the data and went back to using Wi-Fi for the Android system again. This time, when I tried to open the same website, it opened without any problems. I cleared my browser history, cookies, and other data and tried to open the same website using Wi-Fi on my mobile device, but it did not load.

The blocked websites include trusted websites like this site and some government sites. I tried to use Google DNS and different DNS providers, but the results were the same. Currently, everything seems to be working normally, but I am trying to understand what happened and if there is anything I can do. Thank you in advance.


First, welcome to the openSUSE Forums.

It seems that, the Internet Domain Name System servers offered by your Internet Service Provider are having issues providing the name to address resolutions.

Are you using the systemd “nscd.service” to handle your system’s DNS requests?
Is the file ‘/etc/resolv.conf’ a link to ‘/run/netconfig/resolv.conf’?
Is the DNS resolution set up by means of the following entries in the ‘/etc/sysconfig/network/config’ file?


Is the router you’re using to connect to your ISP properly setup to handle the DNS servers offered by your ISP?