I am trying to do an upgrade

From 12.3 to 13.2 by booting from a DVD. I picked that method rather than the zypper since it seemed to be marginally safer.
i also have another partition with elementary linux which can be removed if necessary. I was hoping that 13.2 could be loaded on top of 12.3 and everything else would be left alone. Apparently not so easy.
So, I did a backup of /home, burned the DVD with 13.2, and booted from it.
and then I stopped as nowhere can I see that the script that I am following looks anything like what I see on the screen.
Does anyone have an accurate, workable script that I can use ?

some things that caused me to pause/abort

create root volume /dev/sda5 10.00gb btrfs

Arent there some problems with btrfs and is this changing what it was from 12.3 ?



You are doing a fresh installation apparently.
Choose “Upgrade” on the installation DVD’s boot menu, to do an upgrade instead, this should not create any new partitions.

And 10 GiB for / is probably much too small anyway (especially if you use btrfs).

ok, trying the upgrade path, and then I get to the part where it says the network is not configured and if I say I would like to configure it, the yes button does nothing.
so I took no and I get an error that it cannot download a list of repositories. Makes sense if there is no network.
clicking ok and it proceeds and lists the change settings and I am afraid to proceed, so I do nothing cause something doesn’t seem right.

Forget that you can do that after the install.

ok, it’s off and running. Some 3000 + packages.

It seems to have finished and when I rebooted, it opened a terminal window and asked for my ID and password.
ok, that worked but I am looking for my normal desktop.
So, how do I fire it up ?

It should start automatically. If it doesn’t something is wrong and it won’t start when you “fire it up” manually either.

Try to select “Recovery Mode” in “Advanced Options” in the boot menu that should get you a GUI.

I suppose you had the proprietary nvidia driver installed?
You have to upgrade/reinstall that too.
If you installed it via the RPMs from the repo, open YaST->Software Repositories and change the URL of the nvidia repo to say “13.2” instead of “12.3”.
Then “Upgrade Unconditionally” all nvidia packages to the current versions in YaST->Software Management.

Or uninstall all nvidia packages, remove the repo and click on the 1-click install again.

No gui.

can I do this from a terminal ?
rebooting in recovery mode leads me back to a command prompt
and how do I open Yast from a terminal ?
and yes it is Nivdia
Since I answered no to the install question about not having a network and other repos, do I even have Nvidia ?

Log into the terminal as root type yast

NVIDIA is proprietary it does not get shipped or upgraded by any normal upgrade method.

If needed you can also set you network on there Just like the GUI version just have to navigate via arrow and tab keys

Ok, I am logged in and started yast though I cannot read the left side as it is off the screen.
now what ?

I typed in Nvidia and got about 12 modules. Now what shall I choose. .
bumblebee ?
or other like Nvidia-computeG02

Hm. Recovery mode should get you a GUI even with a broken nvidia driver installation (unless you use GNOME, but even then you would get a graphical error screen).

Try logging in as root, and then run “startx”.
Does it work, or do you get an error message? (if the latter, please post it if possible)

Try to remove /etc/X11/xorg.conf if it exists, and you might get a GUI with a normal boot, if the nvidia driver is the problem.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Since I answered no to the install question about not having a network and other repos, do I even have Nvidia ?

If you had it installed before the upgrade, it will still be installed (the old version).
And if you had the network configured before the upgrade, it will still be configured.
The installer only offers you to configure the network for the installation, to be able to use online repos for the installation.

Well, you could also use zypper to remove the nvidia driver.
For the G02 driver:

sudo zypper rm x11-video-nvidiaG02

For the G03 driver:

sudo zypper rm x11-video-nvidiaG03

If you are not sure, try both lines.

If you have an /etc/X11/xorg.conf, you should remove it as well to get a GUI.

Well I found some old notes that say to try some zypper stuff for Nvidia and I am trying them now. I think I got them from Wolfie.

Bumblebee is for Optimus systems only, i.e. laptops with hybrid intel+nvidia graphics.
And there you only need it for turning off the nvidia card (to save power) and switching to the nvidia card.
Without it the GUI should still work, as it runs on the intel chip anyway.

or other like Nvidia-computeG02

No, for a “normal” nvidia system (i.e. non-Optimus), you need either x11-video-nvidiaG02 or x11-video-nvidiaG03 depending on your graphics card. And it should already be installed anyway, no?
What graphics card do you actually have?

But again, you have to change the nvidia repo to 13.2 (in YaST->Software Repositories) first before you can upgrade/install a working driver.

Unless this is an Optimus base notebook NO bumblebee

That seemed to have done it so far. At least I have a desktop. So now I will go test stuff out.
you folks are the best but surely, there must be a better way than to have to depend on some scribbled notes from2 years ago.
Nvidia is the culprit but can’t this be made easier ?


Not really. The nvidia driver cannot be included in openSUSE because of legal/license reasons.

The only way to make this easier is remove the nvidia driver altogether and use the included open-source nouveau driver.
But that one doesn’t offer the same performance (regarding 3D mostly, the rest should actually be ok nowadays), and it might also have problems with your particular card.

I seem to be missing a disk drive.
it is a HDD plugged into a usb cage and used to be SDF something. It s not there now.
after I get done doing the yast update, I will try and find it.

If you did not explicitly include it you have to mount it or added it to the fstab you can do that in yast

Ok, now to solve the mount issue. 1st off I don’t know why it did not mount as it was installed and powered on when I did the upgrade.
The device is a Western Digital 500MB HD, installed in an external cage which is connected via USB
There is another USB device (SDG1), also present and it is mounted correctly

hexdump@Corky-PC:~> df
Filesystem     1K-blocks     Used Available Use% Mounted on
/dev/sda2      202653592 17424316 174912016  10% /
devtmpfs         1891532        8   1891524   1% /dev
tmpfs            1897780    38444   1859336   3% /dev/shm
tmpfs            1897780     9460   1888320   1% /run
tmpfs            1897780        0   1897780   0% /sys/fs/cgroup
tmpfs            1897780   348844   1548936  19% /tmp
tmpfs            1897780     4040   1893740   1% /var/log
/dev/sdb2       20027260    44976  18941900   1% /sdb/sdb2
/dev/sdb1      759717488 32967840 688135172   5% /home
/dev/sr0         4568574  4568574         0 100% /run/media/hexdump/openSUSE-13.2-DVD-x86_640051
/dev/sda3       20510716 10255688   9190072  53% /run/media/hexdump/a6b719f8-bf8e-427e-906b-3bc568112603
/dev/sdb5      177424936  4581048 163808112   3% /run/media/hexdump/7ce5c1b1-42f1-4618-8a02-30f8df4410c6
/dev/sdg1       15622160   176624  15445536   2% /run/media/hexdump/STORE N GO

mount -l

/dev/sda2 on / type ext4 (rw,noatime,discard,data=ordered)/dev/sdb2 on /sdb/sdb2 type ext4 (rw,relatime,data=ordered)
/dev/sdb1 on /home type ext4 (rw,relatime,data=ordered)
/dev/sr0 on /run/media/hexdump/openSUSE-13.2-DVD-x86_640051 type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=100,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
/dev/sda3 on /run/media/hexdump/a6b719f8-bf8e-427e-906b-3bc568112603 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
/dev/sdb5 on /run/media/hexdump/7ce5c1b1-42f1-4618-8a02-30f8df4410c6 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
/dev/sdg1 on /run/media/hexdump/STORE N GO type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2) [STORE N GO]

I looked in Yast and using Partition, Yast sees the device (sdf1), but it is not mounted. When I looked at doing the mount, I did not have an option to mount it where the other devices were mounted. “/run/media/hexdump”. My options were /usr/local or /srv.
I did neither since I have no clue what impact it might have being different than the other devices.
Since it is a USB device, it might wind up being plugged into a different USB slot if that makes a difference.

Also, I would prefer a permanent solution, not a command line option that I would have to key in after every reboot.