I am new to OpenSuse Tumbleweed XFCE & Have a few Questions?

To the “op” regarding your second question on your thread.
The thumbnails not appearing looks like a gvfs problem even on iphone it doesn’t show thumbnails in thunar.
On my iphone I use ifuse for mounting and can see the thumbnails in thunar.
Find out on your side how to use fuse to mount your android phone.

1 Like

Why? Just plan a maintenance window once a week or so and then (amongst other things you do for managing the system on a regular interval), do the zypper dup. No need for en end-user in a desktop to look nervously to some applet that may turn red or so.


While I am still new to it, the biggest obstacle for me using Yast GUI not terminal, was when you click on something in a few places a menu would open and there were Tabs with other options. Something I wish was added would be some icons to those tabs or different colors because they aren’t always noticed. Once I got myself used to looking for them it made things a lot easier, although that being said I am not expert at using Yast, but it’s something people need to realize, uniformity can be a great thing where aesthetic’s go, but it can also be a distraction if you can’t find what your looking for because it all looks the same. Just some simple Icons to the left of the Tabs would make a world of difference, or perhaps a color change on the selected tab when selected or opened would make a big difference in noticing the extra stuff.

You can change the look of yast2 by using qt5ct as root.
The changes in qt5ct reflects in the yast2 gui if you are using the yast2 qt.

1 Like

To the op I do zypper dup everyday in tumbleweed :grinning:


I just can’t figure it out, I’ve tried installed gvfs everything on OpenSuse, but I ran across this in other distro’s also, the weird part is it shows them in Nautilus. Which I could just simply use Nautilus but I don’t like it, so I wrote a simple script to open nautilus after I connect my phone and select on the phone FILE Transfer I run the script and it opens Nautilus in the Phones Pictures Dir and beside it it opens Thunar in my Downloads directory so I can copy/move them to that directory, this way I can view the thumbnails in Nautilus and copy them over to Thunar which is what I use and see the Thumbnails before copying them. Not the greatest of solutions but it is very easy. I have had this problem on all Disto’s I have used from Debian, Arch, Fedora, and of course OpenSuse, but it’s not a distro issue, it’s a MTP issue I suspect and either way, finding a solution at least is a good thing.

Per My script it’s a simple bash script, I wont bore anyone with it, but basically after I connect an android phone and select for it to have file transfer so it will be noticed by the file browsers, Then I run the script which opens Thunar using wmctrl using a specific size and location and folder which for me is Downloads, and have it open Nautilus doing the same thing with wmctrl in a different location since I am connected already it opens the folder on the phone where the pictures are, so I have Thunar on the left and Nautilus on the right that shows me the thumbnails in Nautilus where I can drag/drop select copy to the Thunar downloads directory. Then do as I want with it. Rather than IMPORTING the entire thing every single time.

Shotwell worked for me plugging in the phone, but the problem with it was I don’t want to import my entire phone pictures every single time, I would rather have an option to view them first and then copy them over.
I don’t want to IMPORT anything, I want to view what I want to COPY over to my PC, not just copy everything and SYNC it so to say.

I’m just not into this SYNC everything, I don’t sync nothing. I would rather do that backup stuff myself.

But anyway, Probably not the best of solutions but it does work. On a side note, When Nautilus is opened I can right click and select to have it open with a photo viewer such as Gthumb and all the others seem to work at that point where I can select copy to or save as for the photo’s that way also.

The main reason I have been trying to figure this is out is I have others I have installed Linux on which they are more than happy with except the thumbnail view in the Thunar file manager, would be nice if I could simply open two Thunar file managers and view the thumbnails and drag and drop the photo’s from an Android phone to PC.

But either way, that’s what I did and it works. I hope I explained it right. Sure I could just copy ALL the pictures over without viewing them, but I would rather ONLY copy the ones I want to.

What about us lazy people, who just want to be told what to do and when? LOL! Kidding… :rofl:

Now please, please, please. This thread is already a mess having three questions. And now we wonder to the next question/problem/suggestion. Can we all stay on topic please? Else this thread will be closed awaiting the opening of new threads each dedicated to a single problem/question with a good title that will draw the attention of people interested in the subject (and thus not in the vague “I have a question”).

1 Like

One of the mods here suggested one use
sudo zypper --verbose dup --allow-vendor-change --details
I do so on a regular basis, works perfectly.

As the -vvv and the --details are only to give more information, but do not influence what is done and as the --allow-vendor-change is since years the default with zypper-dup on Tumbleweed, that is technically the same as

zypper dup

Default is --no-allow-vendor-change.

Oh, oh, oh. Am I blundering. :cold_sweat:

Yes, yes, yes, --no-allow-vendor-change is the default (on Tumbleweed) and for a reason! You should NOT allow vendor changing as that could undo your earlier choice for e.g. a Packman version of a package.

I am still wondering why we have now a number of threads where people not only ask how to install new Tumbleweed snapshots, but then are not satisfied with the answer zypper dup. It looks like a plague. And now apparently I got it also. :face_with_thermometer: