Hybrid Ryzen/Nvidia - No HDMI output


I have this issue. since an earlier update around starting this year, the HDMI output is not working anymore, the same happened in Windows. I had in my mind some about the cable or the port, but checking in Windows, reverting the driver to the original one, the HDMI output worked again, so I tested, the problem comes from the AMD driver.

Of course I could revert all my system to a very old snapshot but I know it won’t work in a next kernel update.

And, when I plug the external monitor, I see an error: [drm:dc_link_detect_helper [amdgpu]] ERROR no EDID read.

Just guessing, but I’d try a new cable anyway. EDID is the monitor info read by the driver from the monitor firmware. A defective cable could still work but fail to transfer EDID info. This actually happened to me, although IINM not on a HDMI connection. Perhaps windows have a default EDID database when it can’t retrieve it’s info from the firmware, or something like that.

Again, just guessing. YMMV.

Hi @brunomcl,

I already tried with another cables. In Windows happened the same, I only reverted the driver and it worked again. But by curious I reverted to a very old snapshot and it didn’t worked what let me surprised.

I was thinking in the port but, again, Windows plays in this guessing. If the port is damaged, Windows simply wouldn’t detect the port, but with the newest drivers, Windows tries to recognize the plugged monitor but immediately is unplugged, flashing only once the external monitor. Same situation in openSUSE.