HW modem connects but ppp dies w/e #2

Please help!
I just loaded 11.2 & Kde 4.3. Installed both Kinternet and Kppp. My modem is a USR PCI HW modem 2976. Hardware Info shows it connected to /dev/ttyS4.
I configured the modem with Yast as modem0. The user access box is checked for Kinternet Both Kppp and and Kinternet will dial out.

The connect response comes back from the ISP and either of the dialers will hang and the dial tone comes back.

The firewall is showing modem0 in the External section. Nothing changes if I shut the firewall off.
There’s nothing in the dmesg I could find.

Could this be a pppd permission problem?
Hope to hear back!

What does kinternet Connection Log (right click on kinternet icon) after a failed attempt indicate? Two things I can think of having used in the past a Dialup connection is that smpppd is not running (check installed and runlevel) and that in the YaST modem setup> Connection Parameters section that Ignore prompts is checked.

Hope that helps.

Thanks for the quick response, Matt,
How do I get DNS resolution working?
The connection is working now (see below), but I can only browse with my ISPs absolute IP address numbers. Even buttons on my IPSs display bring up Page not Found!
For the connection, smpppd was running. In the Sysconfig Editor > Hardware > Network > IO in USERCONTROL there is a yes/no checkbox. Changing that to Yes fixed Kppp. Next, changing Ignore prompts to Yes in the Modem configuration fixed Kinternet.
Thanks for your help this far. To the DNS should be simplier to fix, but I haven’t found the magic!
Stick with me please!

Good, you got some of the things going at least. Do you have IPv6 disabled? This can interfere with page loading for some ISP’s. There is a check block in Network settings but in 11.2 it does not always disable properly. There is a How-to on the Forum for totally disabling IPv6.

I do not know if it is possible to change the DNS for a Dialup type connection other than what the ISP provides. Someone else might know.

Thanks again Matt!
In the Yast Network Devices > Network Settings, I unchecked IPv6 and the Global tab Default route. The reason I’m online with this now tho, I think, is that on another computer I searched for the DNS IPs of my ISP.

They are hard-coded into the Hostname/DNS tab page.
There must be a better solution, but this is working! Just unchecking the IPv6 didn’t change anything.

Another thing if you will, please introduce me to the KnetworkManager! So far I haven’t been able to corner it. Invoking it from the Lizard makes the taskbar flinch like a bullet went thru it, but there’s no bullet hole!

That app must have some shorter exectible handle, but the doc writers have covered their tracks well!

In desparation, on this last gasp, I loaded the Kde3 Networkmanager, thinking that kppp and kinternet are kd3 applications. That put another self-healing bullet hole in the task bar!

Have you ever met an application you didn’t like? Knetworkmanager is disabled now in the Network settings in favor of Ifup, but I think it’s still grinning!

I should be able to make it from here now unless you have a comment to avoid hardcoding DNS.

Thanks again, Heboland