Hulu Desktop...

… For Windows and Macs, not Linux.

Has anyone been able to get this working with Wine on Suse?

It looks like someone got it to work on Ubuntu. But for me it will install, start and not connect. Well it will start as soon as it installs but if I click on the link in the Menu under Wine it doesn’t do anything, just hangs then stops. So I know I am missing a few things.

Hulu - Labs: Hulu Desktop

WineHQ - Hulu Desktop Beta

me neither, just sits and eats cpu

works here wine version 1.1.27. desktop shortcut does not work and I have to run it from a console, but it works](

hmm - works as a diff. user but not as me but must be something in my .wine directory

still used immense amount of cpu

google01103 wrote:

> hmm - works as a diff. user but not as me but
must be something in my
> .wine directory
> still used immense amount of cpu
[Resolved] Ok - problem was Flash version, by
uninstalling Flash and letting the Hulu install
program dl and install Flash it now works.

Still uses massive amounts of cpu

Executable in strange place:

openSuse 11.1 x64bit, KDE4.x Factory, Opera

Has anyone tried out Boxee? It may be better that Hulu desktop. Plus you get more to choose from.

There’s no rpm (that I’ve been able to find) for openSuse and Hulu has occasionally blocked Boxee from access to their service, of course then Boxee creates a workaround. The only Linux package I’m aware of is for Ubuntu.

RPM Search boxee-

Converted .deb package using alien. First search result for

boxee .rpm

Haven’t tried it as I’m at work.

Take Care,


Edit: you said for openSUSE so my mistake. It’s for Fedora.

I’m 64bit and the official Ubuntu .deb is 32bit (as is the Fedora rpm) so I’m thinking Alien isn’t gonna work for me.

According to Google there is (was) a Hulu addin for XBMC (which is what Boxee is based on) and XBMC is available from Packman and the addons are available Downloads - xbmc-addons - Project Hosting on Google Code but not sure there is a working Hulu addin (will post after dl and install later today)

Could not find Hulu addon for XBMC, has anyone?

Boxee installs are available in format, check the website out at BOXEE: the open, connected, social media center for windows, mac os x and linux

in hulu labs there is a linux beta for huludesktop
Hulu - Labs

my experience is 64 bit seg faults immeadiatly though the 32bit works well (but I need to buffer, by pausing, a fair amount for the sound to not sputter on my slow dsl)

on a 64bit system to run the 32bit client you must install 32bit flash and edit ~/huludesktop to point to it

  • openSuse 11.0 64-bit
  • Flash
  • Hulu Desktop

I am trying the new Hulu Desktop on Suse 11.0

Hulu - Labs

I can play regular Hulu videos just fine in Firefox using the npwrapper for Adobe Flash 9.

I installed the Hulu Desktop rpm and the first thing it said was it could not find

I remedied this by editing the ~/.huludesktop file and explicitly adding the location of the library. In my case I use npwrapper for 64 bit, so:

flash_location = /usr/lib64/browser-plugins/

However, with Hulu Desktop this presents a problem in full screen, where the video staggers. It’s smooth in small screen view. (This is odd because in Firefox, full screen works just fine!)

Next I tried the new Adobe 10 64-bit flash beta from Adobe which they say they tested with openSuse. They also say I don’t need the npwrapper.

Adobe Labs - Downloads: Flash Player 10 for 64-bit Linux

When I downloaded it (just a single file) and configured Hulu Desktop to use the Adobe 10, it worked great in full screen and small screen…but no sound! Why?!

Any other beta testers out there for Hulu Desktop?


Hey, I fixed it!

In the process of trying another “fix” I installed asla-plugin-player. At that point, it broke my Flash 9 as well.

So, then I uninstalled it.

I decided to try the Adobe 10 for 64-bit – and wouldn’t you know … it works!

So now I have:

  1. Hulu Desktop
  2. Using the native Adobe Flash 64-bit library from Adobe (no wrapper)
  3. Sound
  4. Full screen without jitter!

I’ve got it working in 11.2 M-8 x86_64 with 64 bit Flash Player. Installed Fedora x86_64 .rpm with ‘Install Software’ and had to edit ‘~/.huludesktop’ for path to ‘’. Watched episode of the The Office. This is something I can use to pursue mindless entertainment. >:)rotfl!

having installed the fedora x86 rpm
and editing the .huludesktop to

flash_location = /usr/lib/browser-plugins/

mine still complains of the missing

it seems to not be reading the updated .huludesktop

anyone have this problem after properly modifying the .huludesktop file?

apparently just downloading and putting its path in the flash_location in .huludesktop does not work, I had to put in /usr/lib64/browser-plugins/ then it worked fine.