huawei usb dongle not working on tumbleweed

I run Tumbleweed on our GNU/Linux club laptop, and also on an old home PC, but not on my main PC. I find Tumbleweed a bit too cutting edge for my main PC and for that PC I share your view.

Having typed that, I do note that sometimes one can discover problems in Tumbleweed, that are about to appear in the next openSUSE release. That was the case for my ‘old home PC’ where there was a nouveau driver problem that I first encountered with an updated Tumbleweed kernel. Only rolling back the Tumbleweed kernel to an older kernel restored the graphics. Warned of this problem, I then started installing the latest milestone releases of the upcoming openSUSE version (in a separate partition on the same ‘old home PC’) where those milestone releases had the same problem. A bug report I raised on the Tumbleweed/Milestones was fortunately in time to have a fix produced, and then the fix was in the GM release of that new openSUSE version.

So there can be benefits from installing Tumbleweed. I think I take a small risk with my main PC by not installing Tumbleweed (although I do boot my main PC to the latest milestone liveDVDs when they are available - with the intent of catching any new major bugs that might impact me as soon as possible).

You may wish to try the latest milestone releases of openSUSE-13.1 (via liveDVD) to see if they have the same problem as you experienced in Tumbleweed. If they do, then raise a bug report so to have the developers/packagers support a fix in an area that is important to your PC.

thanks oldcpu but dvd download is out of the question for me as I only have 10 gb month to use for internet and that costs me just on 60 dollars,I can still conect to the internet via plugging my usb dongle into wifi router and conect via etho just the dongle was working fine on 12.3 so there is some bug as the network manager doesnt give me an option to add true move to network manager in the drop down tab on 12.3 it gives me all internet service providors in Thailand so just have to wait for one of the dev,s to pick up on this problem ubuntu,linux mint and fedora all pick up the dongle fine as did 12.3 but tumbleweed no I will just keep trying mate thanks for your help
regards Ron

its still doing the same as before deano so nothing has changed from previous attempts will keep trying though
regards ron
yes I would like to get the 3g modem working but looks like it wont at the moment

So, please carefully follow my instructions as per post #15. (I want to know if we can manually switch the mode state of your device.)

it just doesnt work deano there is some bug in networkmanager that wont open add new conection so there is no point for me to pursue this issue as I think the software is just not up to speed for a rolling distro

Okay, I understood you were having troubles with the actual USB modem state. The device would have to be present and working in order for the Network Manager to offer any options related to mobile broadband. If it is just a NM configuration issue, then perhaps ModemManager, or or one of the NetworkManager packages are the problem

 rpm -qa|grep Manager

heres the output deano

Right back at the beginning of this thread, you reported the output of ‘usb-devices’

T:  Bus=02 Lev=03 Prnt=04 Port=02 Cnt=02 Dev#=  8 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1446 Rev=00.00
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:  #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 1 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

That and your dmesg output

desktop:~ # dmesg|tail
  236.865199] usb-storage 2-1.8.1:1.1: USB Mass Storage device detected
  236.865225] scsi11 : usb-storage 2-1.8.1:1.1
  236.865272] usbcore: registered new interface driver usb-storage
  237.873399] scsi 10:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
  237.873851] scsi 11:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
  237.874372] sd 11:0:0:0: Attached scsi generic sg5 type 0
  237.876130] sr1: scsi-1 drive
  237.876602] sr 10:0:0:0: Attached scsi CD-ROM sr1
  237.876856] sr 10:0:0:0: Attached scsi generic sg6 type 5
  237.877236] sd 11:0:0:0: [sde] Attached SCSI removable disk

suggested a problem with your device being in ‘storage’ mode, rather than ‘modem’ mode. Correct? If that is still the case, then it needs to be solved before NetworkManager will be able allow you to configure the device.

Looks okay at a glance.

well looks to me like they just cant get it to work on tumbleweed

Okay, I see no answers from post #15. No proof that the modem is in the right mode. I can’t help further. Good luck with tumbleweed.

desktop:~ # /lib/udev/usb_modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd
desktop:~ # lsusb
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 046d:0809 Logitech, Inc. Webcam Pro 9000
Bus 002 Device 007: ID 174c:2074 ASMedia Technology Inc.
Bus 002 Device 008: ID 2109:2812
Bus 002 Device 009: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 011: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)
Bus 002 Device 010: ID 046d:c526 Logitech, Inc. Nano Receiver
here it is deano

Hmmm…doesn’t look like it’s switching at all.

1.You could try invoking

 /usr/bin/eject /dev/sr1

then check the product ID again (with lsusb). It should have changed from 1446 —> 1506 (or similar)

  1. Do you have ‘usb_modeswitch-data’ installed? It provides a number of files, including ‘/usr/share/usb_modeswitch/12d1:1446’
rpm -ql usb_modeswitch-data|grep 1446

That file should contain

# Huawei, newer modems

TargetVendor=  0x12d1
TargetProductList="1001,1406,140b,140c,1412,141b,1433,1436,14ac,1506"

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

That is what usb_modeswitch uses to switch the device mode (from storage to modem). There is a rule file (/lib/udev/rules.d/40-usb_modeswitch.rules) that should be present. It has an entry to deal with your device upon detection (automatically)

# Huawei, newer modems
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="usb_modeswitch '%b/%k'"

Maybe something has changed with the tumbleweed package updates? Anyway, you should check that the above exists.

yes all the above exists I did like you said still nothing never mind we tried
thanks regards Ron

I recommend filing a bug report then.

how do I post a screenshot of my disks

Hi there. I’ve had similar problems with my own 3G card, on stable openSUSE 13.1. I’m not sure if it’s the same issue as here… but just in case, here is the thread describing my problem.

https://forums.opensuse.org/english/get-technical-help-here/hardware/492309-3g-modem-doesnt-work-when-connected-usb-hub.html