Huawei SmartAX MT810 connection at boot (arnet)

Suse was my first Linux choice five years ago.
I was absolutely dazzled, but my wife made me drop it after 20 days of not being able to get an internet connection.

I thought of trying again after so long to see if things had become easier for every Argentina user who has a Huawei connection (more than half of the country).
Unfortunately not.

The problem is the following:

I have a Huawei SmartAX MT810 usb-modem/router. In order to establish a connection, I need to run the following commands AS ROOT (which is why I cannot use a simple kde autostart bash script)

modprobe br2684 ; br2684ctl -c 0 -b -a 0.33 ; ifconfig nas0 up ; pppd call adsl

What’s more, these commands cannot be run before the modem is operational, since they will end with an error.

In other distros I used to place these commands in /etc/rc.local.
I tried placing them in /etc/rc.d/boot.local , but with no success: they are executed before the modem is operational.

In my complete ignorance of all things computer-related I thought it would be a good idea to place a caveat before the execution of the commands:

READYorNOT=$(dmesg | grep "modem operational") ; while   "$READYorNOT" = "" ]  ; do echo "Modem not operational" ; done 

As a result the whole boot sequence gets stuck until I hit ctrl-c.

Could anyone lend me a hand, please?

**By the way:: I’m not complaining about anything; I’m just asking for help. I would LOVE to be able to stick with openSUSE.

**

Hey I am not so sure of your problem as I am not a geek myself, but I too faced a problem with Huwei USB modem as Linux Kernel 2.6.28 in opensuse 11.1 did not support USB modem. I had to manually enter a list of commands to make system recognized it as a USB modem. But, that problem was solved in Kernel 2.6.30 and opensuse 11.2 is having Kernel 2.6.31. My Huwei USB modem is working fine in suse 11.2. Are you also using 11.2 or some previous version?

Sorry. I forgot to mention those details:
openSUSE 11.2 (x86_64)
2.6.31.8-0.1-desktop

oh… then are you sure that your USB modem is not working before you execute these commands? In the Knetworkmanager configuration panel there is a tab for “Mobile Broadband” where you have to enter your modem details. Is it not there, or is it not working?

Vivhek:
Knetworkmanager shows no available connections, even when I am actually connected.

However, I am getting closer:

  1. I edited sudoers as follows:
ALL	ALL =  NOPASSWD:/sbin/mount /cdrom,/sbin/umount /cdrom,/usr/sbin/pppoe-start,/usr/sbin/pppoe-stop,/usr/sbin/pppoe-connect,/sbin/modprobe br2684,/usr/sbin/br2684ctl,/sbin/ifconfig nas0 up,/usr/sbin/pppd call adsl
  1. I created an alias in ~/.bashrc:
alias CON='sudo /sbin/modprobe br2684 ; sudo /usr/sbin/br2684ctl -c 0 -b -a 0.33 ;  sudo /sbin/ifconfig nas0 up ; sudo /usr/sbin/pppd call adsl'
  1. I created a panel icon with the above command.

That way I can either type CON or click the icon to connect.

I also tried creating an executable bash script with those commands and placing it in the autostart folder, but it didn’t work. My guess is that the boot time of this beautiful distro is (unfortunately) too fast, and it executes the script before the modem becomes operational (about 15 seconds).

Thanks for your replies, by the way.
If you have any more ideas, please let me know.

knetworkmanger will not just show available connections when you are connected. First you will have to configure your connection. Let us get it step by step.

  1. Open Yast Administrator Settings and select Network Settings.
  2. There on “Global Options” tab choose “User controlled with
    Networkmanager” option. Check this snapshot Picasa Web Albums - Vivek - knetworkmanag…. Hit OK and wait for it to complete the configuration.
  3. Just restart the system.
  4. After you restart the system, plug in your USB modem. After
    some 15-20 secs, you will get the kde pop up saying that the USB
    device has been mounted. Now you will be able to see a “Mobile”
    kind of icon in the system tray which is knetworkmanager.
  5. Click on this icon, and then click on “Manage Connections”. You
    will get a windows like this: Picasa Web Albums - Vivek - knetworkmanag…. Select
    the “Mobile Broadband” tab.
  6. Here hit the “Add” buttion present on the right side. There are
    two options there: CDMA and GSM. Mine is CDMA, so I will
    proceed with its configuration here.
  7. If you select CDMA, you will get a window like this:
    Picasa Web Albums - Vivek - knetworkmanag…. Fill anything in
    “Connection Name”. And you will be knowing the details of
    “Number”, Username and Password fields :).
  8. After filling in all the details, hit OK, hit OK again in the next
    window. Now, when you click again the knetworkmanager icon in
    the system tray, it will have the name of connection you have
    configured. Click it, and wait for it to say “Active”. You are ready
    to go now, you are connected to the Internet.

Please let me know if I have totally misunderstood you… :slight_smile: Hope I am helping you…

Vivhek:
Thanks for your precise instructions.

Unfortunately, when I plug in the usb modem, nothing happens with knetworkmanager (it is running).

Fortunately, I have solved the problem:
I placed the script in the kde autostart folder and then went to System Preferences … Autostart.
There I chose “kde prestart” (my system is in Spanish, so I’m just guessing the English version).
This moved the script out of ~/.kde4/Autostart/ to ???.
I don’t know where it landed, but NOW IT WORKS.
I think I’m beginning to fall for SUSE. (I hope my wife doesn’t read this).

A million thanks again for your time.
I’ll go back to trace the whereabouts of my script.

Found it: ~/.kde4/env

Do you people not have the custom of marking posts as solved?

Congrats!!! That calls for a celebration :slight_smile: This is the beauty of Linux… You can do a thing in ten different ways… All that matters is that it works for you now… and no, the threads can not be marked as “Solved” here…