huawei k3565 connection problem

Hello everyone

i bought a modem (huawei K3565) and I cant get it to work. the problem seems weird and on betavine.net I found a couple of people who are having the same problem but no one really came up with a solution to it.

I will try to describe the problem step by step.

I installed both umtsmon and vodafone mobile connect card driver for linux from betavine.
after several unsuccessful tries I managed to find the proper apn on betavine which is PPBUNDLE.INTERNET
now I can get both umtsmon and vodafone to connect (the modems blue light keeps lighting which suggests it is connected). however as soon as i open firefox it says it is offline and whatever i do (file-work offline) has no effect on that.

interestingly enough when I try to start skype it works and I can call!

yesterday late at night it seemed like i got the solution. in knetwork manager I tried to connect with all the necessary details and it did. then I could use everything. but the next day in the morning I try it knet doesnt even start connecting with the same details like yesterday. there is no response whatsoever.

I am not a complete linux noob I have been using it for almost a year now but I am definitely not an expert and this problem seems unsolvable to me. I assume its something with ppp (whatever that is, ok maybe i am a noob

btw I run opensuse 11.1

do you reckon upgrading to 11.2 might help?

I really need to come up with the solution quickly because I am working on a project which requires constant internet connection. If i cant get it done in a couple of days I will have to go back to windows.

so please any help is very much appreciated

thank you so much

Hi,

Often USB modems get the DNS addresses from the ISP when they connect, I
assume, if you can connect using the modem but can’t browse the web in
Firefox, it isn’t getting the nameservers (this is a common problem with
mobile broadband but an easy one to fix); therefore simply adding the
openDNS nameservers to your /etc/resolv.conf file should fix the
problem. If you are unsure how to do this you could do this from the
command line:

su -
(enter root password when prompted)

echo “nameserver 208.67.222.222” >> /etc/resolv.conf
echo “nameserver 208.67.220.220” >> /etc/resolv.conf

logout

Hope this helps.


Regards,
Barry Nichols

thank you very much for help
it seems like your script did do something, because now umtsmon shows the name of the operator and the traffic and vodafone driver seems to be more ‘confident’ that it is connected as well. however thats all. knetwork doesnt do anything when I try to connect with it.

so basically I still dont know what to do:( I am connected and can use skype but firefox doesnt do anything.

any suggestions?

thanks

I hope you take my remark lightly, but saying firefox doesnt do anything is not very helpfull to us and probably untrue.

Does it start in a window on your desktop? (Only when there is not even a window you are allowed to say it does nothing).

Can you type an address in the addressbar and hit return?

What happens next? Does the X become red?

Does any message appear in the window?

In short the situation is that you are sitting there and we here and you have a sccreen and we havo no crystal balls.

sorry about that

by saying it doesnt do anything i meant that there is no change to the previous situation whatsoever. so when I open it, it jumps directly to the ‘offline mode’ window which just says that it cant open the page because it is offline. I think its that standard page it opens when you are not connected to the internet. but other than that it works properly, i can type whatever, change the settings… firefox works, it just cannot use the internet connection that has been estabilished

Try konqueror. Only to have a reference to what another one thinks about it.

On 03/12/2010 05:46 PM, tarkowski wrote:
>
> Barry_Nichols;2135308 Wrote:
>> Hi,
>>
>> Often USB modems get the DNS addresses from the ISP when they connect,
>> I
>> assume, if you can connect using the modem but can’t browse the web in
>> Firefox, it isn’t getting the nameservers (this is a common problem
>> with
>> mobile broadband but an easy one to fix); therefore simply adding the
>> openDNS nameservers to your /etc/resolv.conf file should fix the
>> problem. If you are unsure how to do this you could do this from the
>> command line:
>>
>> su -
>> (enter root password when prompted)
>>
>> echo “nameserver 208.67.222.222” >> /etc/resolv.conf
>> echo “nameserver 208.67.220.220” >> /etc/resolv.conf
>>
>> logout
>>
>> Hope this helps.
>>
>> –
>> Regards,
>> Barry Nichols
>
> thank you very much for help
> it seems like your script did do something,

Those commands added two nameservers to your /etc/resolv.conf.

because now umtsmon shows
> the name of the operator and the traffic and vodafone driver seems to be
> more ‘confident’ that it is connected as well. however thats all.
> knetwork doesnt do anything when I try to connect with it.

Are you saying that you have UMTSMON and VMC running and you are trying
to connect with knetwork?

First stop them all. Then make sure that you have the following:

YaST > Security and Users > User and Group Management > Users > Edit >
Details > Additional Groups.
Here you tick groups dialout and uucp.

After this the user needs to log out and back in to make the group
changes to take effect.

Then start UMTSMON, click ‘connect’ and start Firefox.

Vahis

“Sunrise 6:48am (EET), sunset 6:13pm (EET) at Espoo, FI (11:24 hours
daylight)”
http://waxborg.servepics.com
Linux #1 SMP 2010-01-14 18:58:36 +0100 x86_64
6:19pm up 20 days 10:48, 14 users, load average: 1.10, 0.45, 0.20

thanks
I wasnt trying to connect them all at the same time but separately. I ticked the group uucp (dialout was ticked already) as you suggested but nothing seems to change. umtsmon is capable of making the connection, but it wont communicate with firefox. i tried conqueror as well, but it can’t connect to the internet either. it shows the page which says that i am not connected.

meanwhile i tried knetwork again and it cannot connect through the modem. i dont know why though. yesterday it worked for a while.

so umtsmon and vcd can connect but wont ‘communicate’ with firefox only with skype. knetwork cant connect, but i believe if it did, it could make the connection.

what does skype do that firefox doesnt?

i wish i was just a bit better with linux, I am sure I could work this out (I am sure you guys could as well if you had my pc in your hands for like 5 minutes)

thanks again

On 03/12/2010 07:26 PM, tarkowski wrote:
>
> thanks
> I wasnt trying to connect them all at the same time but separately.

It looks like the replies are getting a bit mixed up.
Your reply seems to be to mine, so I’ll continue.
Let’s try to keep them straight from now on…
> I
> ticked the group uucp (dialout was ticked already) as you suggested but
> nothing seems to change. umtsmon is capable of making the connection,

What happens if after connecting via umtsmon you type in konsole:
ping google.com

Vahis

“Sunrise 6:48am (EET), sunset 6:13pm (EET) at Espoo, FI (11:24 hours
daylight)”
http://waxborg.servepics.com
Linux #1 SMP 2010-01-14 18:58:36 +0100 x86_64
9:00pm up 20 days 13:29, 15 users, load average: 0.31, 0.22, 0.15

OK so i did what you suggested and this is what i got

denis@linux-3q49:~> ping google.com
PING google.com (66.102.9.147) 56(84) bytes of data.
64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=1 ttl=53 time=387 ms
64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=2 ttl=53 time=387 ms
64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=3 ttl=53 time=332 ms
64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=4 ttl=53 time=319 ms
64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=5 ttl=53 time=324 ms

and on and on

On 03/13/2010 12:26 AM, tarkowski wrote:
>
> Vahis;2135482 Wrote:
>> What happens if after connecting via umtsmon you type in konsole:
>> ping google.com
>>
>
> OK so i did what you suggested and this is what i got
>
> denis@linux-3q49:~> ping google.com
> PING google.com (66.102.9.147) 56(84) bytes of data.
> 64 bytes from lm-in-f147.1e100.net (66.102.9.147): icmp_seq=1 ttl=53

> and on and on

OK, you can ping Google with its name.
This means that your connection to the Internet is ok.

Now you should be ok with browsers, too, like Firefox.

What happens in there?

Vahis

“Sunrise 6:45am (EET), sunset 6:15pm (EET) at Espoo, FI (11:29 hours
daylight)”
http://waxborg.servepics.com
Linux #1 SMP 2010-01-14 18:58:36 +0100 x86_64
9:02am up 21 days 1:31, 15 users, load average: 0.03, 0.08, 0.08