Huawei e122 HSPA USB stick not working under OpenSuse 11.3

Dear all,
I upgraded from 11.2 to 11.3 and with great disappointment I discovered that my HSPA modem, that worked out of the box under 11.2, work no more.
At the first attempt NetworkManager is able to build the connection, I am able to use Yast to download new packages and online updating but at the first use of firefox the internet connection hangs up. Any attempt to disconnecting/reconnceting the usb stick gives the following error in the kernel echo:

usb 1-5 device descriptor read/64 error -110 

The output of lsusb command was

Bus 001 Device 004 : ID 12d1:1001 Huawei Technologies E620 USB Modem 

instead on the kernel output console (CTRL+ALT+Fn10) we get the following output

sr1: scsi-1 drive
CDROM (ioctl) error, command: Xpwrite, Read disk inf 51 00 00 00 00 00 00 00 02 00

It is useful to highlight that the modem is identified by the manufacturer as an Huauei E122
I would say that a friend of mine borrowed me a Huawei e220 usb card that works out of the box also under 11.3 with the following output of lsusb command:

Bus 004 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem

while the kernel echo was the following:

sr1: scsi-1 drive

So the only difference is the CDROM error
Thanks in advance!

Googling the internet for the ioctl error related to USB modem I found this link:

A Mobile Evangelist’s Deep Dive In Mobi: USB Modem installation in Linux for dummies

an Ubunto user that experienced the same behaviour with an ONDA USB stick modem.
The solution adviced (if I’m right) is to force the OS to consider the USB as a modem. I’m not sure if this could be the solution for your case too, I hope the community would help for this.
Then you should verify if the necessary packages are present in OpenSuse too.

SOLVED: with the last upgrade of the kernel the usb modem runs.
The error

sr1: scsi-1 drive
CDROM (ioctl) error, command: Xpwrite, Read disk inf 51 00 00 00 00 00 00 00 02 00

remains the same but now I can surf the net without any problem.