HTML5 video lags but audio is fine. Any way to use external player like VLC to play twitch streams?

It might just be because this laptop is really old.

Genuine Intel(R) CPU T2080 @ 1.73GHz 2 cores
Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
Memory Size: 2 GB

VLC natively plays youtube urls but twitch urls don’t seem to work.

I looked it up and people are using livestreamer with VLC for twitch, but the livestreamer GUI doesn’t support opensuse currently:
Running firefox in safe mode (no addons) doesn’t change it. I’ve tried toggling hardware accel.

Are there other opensuse programs that might work?

what browser are you using
youtube defaults to webm (vp9 and vp8 video) under linux
you can try and force youtube to give you mp4 (h264) video
under Firefox you’ve got 2 options
#1 disable webm
in about:config find and set the preference media.webm.enabled to false
I don’t recommend this as it will break other sites that don’t offer an alternative
#2 install the addon h264ify
for Firefox and SeaMonkey
for Chromium based browsers

there was a way to use vlc in youtube but that requires you to use a script manager and inject a user script
under Firefox install Tampermonkey (Greasemonkey hasn’t been ported to webext but might work)
for Chromium get it from google store
and import the following userscript
read the greasyfork page for more info, I still thing h264ify is your best choice

Thanks, trying h264ify.

I can’t edit the OP, but enabling hardware accel in firefox seemed to fix the issue with twitch. When I tried it previously with youtube it didn’t seem to have an effect, but that h264ify addon sounds promising for youtube.

Can’t edit my posts but just came across this link for command line instructions for linux that I wanted to add to the thread, but I’m guessing it won’t work for opensuse:

Going to try using for now since I’m still not getting consistent quality from twitch.

as this is a different issue maybe a new thread is a better choice
regardin you should be able to do it in opensuse with a few changes (just replace apt-get install with zypper install)

sudo zypper install python-pip
sudo pip install livestreamer
livestreamer “paste twitch url here” best -o mystream.mp4

it maybe this app
you can get it from the multimedia:apps repo

zypper ar -f
zypper in gnome-twitch

Thanks for the help!

Just for anyone else who finds this thread with similar issues:

The gnome-twitch program is pretty limited. You can’t paste in VOD URLs, and I couldn’t even find the channel of the person who’s VOD I was looking for. It looks like you might only be able to watch/browse live channels. The only tabs/windows/options available in the program are “Channels” “Follows” “Games”, which only seem to let you browse what ever is live under those categories.

For this one:

sudo zypper install python-pip
sudo pip install livestreamer
livestreamer “paste twitch url here” best -o mystream.mp4

“python-pip” can’t be found, but it installs python2-pip instead.

And after installing livestreamer, when I put in:

livestreamer “” best -o mystream.mp4
livestreamer “” best -o mystream.mp4

It says:

error: No plugin can handle URL: “” also didn’t seem to be working. It was staying on “processing” for a really long time. doesn’t seem to work either. Only downloads a small .m3u8 file. Same for even though they both say they support twitch. works ok but only downloads ~1gig/1hr chunks at a time.

“Twitch Leecher” seems to be a good program for this but I don’t see a linux version.

it would seam python-pip is not compiled for TW as only a source package for TW can be found on
currently at version 9.0.1 (LEAP is at 7.1.2)
there is a python2-pip for TW only also at version 9.0.1
they could be the same package
both provide the same function an ability to install python packages
about livestream plugin error try without the quotas

livestreamer best -o mystream.mp4

Without the quotes I get:

[cli][info] Found matching plugin twitch for URL
error: Unable to open URL: (400 Client Error: Bad Request for url:

apparently livestreamer uses a plugin interface
it’s possible pip didn’t install all the plugins
livestreamer has been packaged for TW I’d suggest removing the pip package and install the rpm

sudo pip uninstall livestreamer
sudo zypper in

then try and capture a stream

livestreamer best -o mystream.mp4

I checked the rpm and it does include a twitch plugin

if this doesn’t fix things you really should start a livestreamer thread as the title of this thread is misleading and livestreamer users won’t read it

Also I found this for anyone that wants to download a VOD they like from Twitch

How to convert the mp3 format to mp4 to normally watch the video. The online convector will help in this.

It is suggested that you can download the video and watch it with VLC. If you download the video, you can try this tool: