HSDPA USB Modem ZTE MF622 didn't work with opensuse 11.1

There is a problem in a kernel (from 2.6.26).
Some more information can be founded here

Hopes it will be solved at future kernel releases.

I successfully fixed some problem in device detection of ZTE MF622 by following this instruction:

  1. Modify the /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi

from this

<!-- Qualcomm: Telstra/NextG CDMA , ZTE CDMA Tech →
<match key="@info.parent:usb.product_id" int_outof=“0x0001;0xfffe”>
<match key="@info.parent:usb.interface.number" int=“0”>
<append key=“modem.command_sets” type=“strlist”>IS-707-A</append>

to this

<!-- Qualcomm: Telstra/NextG CDMA , ZTE CDMA Tech →
<match key="@info.parent:usb.product_id" int_outof=“0x0001;0xfffe”>
<match key="@info.parent:usb.interface.number" int=“0”>
<append key=“modem.command_sets” type=“strlist”>GSM-07.07</append>
<append key=“modem.command_sets” type=“strlist”>GSM-07.05</append>

and with this /etc/usb_modeswitch.conf


ZTE MF622 (aka “Onda MDC502HS”)

Contributor: “andylog”

DefaultVendor= 0x19d2
DefaultProduct= 0x2000

TargetVendor= 0x19d2
TargetProduct= 0x0002


the only problem I’m still needing to fix is how to use NetworkManager (gnome/kde4) to connect to the internet. I’m still using wvdial/ppp.

Are you shure that you have solved the problem with device detection in Opensuse 11.1? In Opensuse 11.0 all works fine (except network manager). Your solution didn’t help me at Opensuse 11.1 and all looks like that I need to rebuild kernel manually after remove UNUSUAL_DEV in drivers/usb/storage/unusual_devs.h:
and only this can help me to solve the problem

I’m glad to say that problem is solved!
I used my Windows Vista preinstalled on my notebook to solve this problem.
1.Download QPST (I’ve used 2.7.264 version). It’s easy to find it using google or etc.
2.Install QPST. Configure it on your modem COM port (modem must work as modem not as CD-ROM, COM port has name like “diagnose” or something like that. Find it from windows device manager).
3.Run QPST EFS Explorer and delete CD_STARTUP_FLAG file.

Now, after reboot at Opensuse, modem will be defined normally even without using usb mode switch (at Windows modem will be works normally too, but you must have drivers installed, because after this file is deleted - modem will be run as modem immediately, not as CD-ROM after plug-in).

NetworkManager is works with this modem too! I configure modem using yast-modem as I do it with Networkmanager 0.6.

Once you have deleted the “CD_STARTUP_FLAG file”, is it possible to restore (for example if you want to use the modem in a new windows machine)?

Please, i beg your pardon if the question is silly, but i hadn’t time to check the software (i’ll do as soon as possible).

Tnks in advance!

As I’ve read at others internet resources, Yes, It’s possible to copy back CD_STARTUP_FLAG to restore start “CD” of modem, but I recommend to copy CD and files from modem before delete this file.

Thank you very much monomakh.

QPST is an interesting tool: it can transform a modem in a secret storage usb key (who would search for files in a modem?).

But actually, I solved my problem with a ONDA MT503HT (MF628) using usb_modeswitch.
The software is ready in my OpenSuse 11.1 64 bit, just a little editing on the /etc/usb_modeswitch.conf file and everything is OK, even the built in MicroSD card reader.
Comment out the section “Option GlobeSurfer Icon (aka “Vodafone EasyBox”)” and enable the section “ONDA MT503HS (most likely a ZTE model)”.

Of course some tweaking is needed on the side of /etc/wvdial.conf and, if you don’t want to run usb_modeswitch in a console (as a root), you have to create a new rule for udev.
For example, create the rule with:
touch /etc/udev/rules.d/75-onda-MT503HS.rules
and then insert in the file this string:
SUBSYSTEM==“usb”, ATTR{idVendor}==“19d2”, ATTR{idProduct}==“2000”, RUN+="/usr/sbin/usb_modeswitch"

Thanks to everyone!

Bye, bye.

Hi acez!

I’m trying to install the driver of ONDA MDC502HS on openSUSE 11.0 following the provider instructions (TIM, Italy), but after the commands <make> and <sh install.sh>, it seems, the driver has not been installed. Typing <ls -al /dev/ttyUSB*>, I get the message
“ls: access to /dev/ttyUSB* denied: file or directory not found”.

Could you please explain, how to get the driver installed!
Actually, I didn’t understand, what you wrote in your quoted post - I’m only using openSUSE for 2 years and I’m not a software specialist.

Thank a lot in advance fpr your help

Well, the device is not the same, but an analogy should be ok for you too.

In my post I stated that it is not necessary to install any driver or extra software. Everithing should work from a base install (of OpenSuse). I confirm that i’m still happily using my device (even if sometimes, in particular when signal is very slow, it’s better to turn everything off …, but it’s not a question of how it is configured, but it’s a TIM’s question!).

So my advice is: don’t try to install anything.
Log in as root, edit the “/etc/usb_modeswitch.conf” file commenting out everything except the part relative to “ZTE MF622 aka Onda MDC502HS”.
Insert tha USB device, wait some seconds, launch usb_modeswitch (check in a terminal lspci output before and after launching the usb_modeswitch command). If all is OK, than you can go on with some automation (i.e. create a rule for udev as described → double check the correct idvendor!).

If you are unsure about wvdial.conf, google around there are lots of configuration examples.

Take a look also here:
Slacky.eu -The Italian Slackware Community • Leggi argomento - Hdspa Onda MT503HS (ZTE MF628) e Slackware 12.2

Bye, bye.

Let us know.

Of course, when all is OK, there’s no need to be root to use the device: KNetworkManager is a friend of yours!