HPLIP won't print from kwrite but does print from LibreOffice!

So I discovered that hplip will print from LibreOffice but from kwrite it does not print. And in cups I see:



D [18/Jul/2012:14:52:25 -0400] [Job 43] Error: /stackunderflow in --setpattern--
D [18/Jul/2012:14:52:25 -0400] [Job 43] Operand stack:
D [18/Jul/2012:14:52:25 -0400] [Job 43] --dict:8/8(ro)(L)--
D [18/Jul/2012:14:52:25 -0400] [Job 43] Execution stack:
D [18/Jul/2012:14:52:25 -0400] [Job 43] %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1910   1   3   %oparray_pop   1909   1   3   %oparray_pop   1893   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1860   1   10   %oparray_pop
D [18/Jul/2012:14:52:25 -0400] [Job 43] Dictionary stack:
D [18/Jul/2012:14:52:25 -0400] [Job 43] --dict:1175/3371(ro)(G)--   --dict:0/20(G)--   --dict:84/200(L)--   --dict:68/75(L)--   --dict:19/25(L)--   --dict:8/15(L)--   --dict:0/15(L)--   --dict:0/15(L)--   --dict:0/15(L)--   --dict:8/15(L)--
D [18/Jul/2012:14:52:25 -0400] [Job 43] Current allocation mode is local
D [18/Jul/2012:14:52:25 -0400] [Job 43] Last OS error: 2
D [18/Jul/2012:14:52:25 -0400] [Job 43] GPL Ghostscript  9.00: Unrecoverable error, exit code 1
D [18/Jul/2012:14:52:25 -0400] [Job 43] Rendering completed
D [18/Jul/2012:14:52:25 -0400] [Job 43] Set job-printer-state-message to "Rendering completed", current level=INFO
D [18/Jul/2012:14:52:25 -0400] [Job 43] prnt/hpcups/HPCupsFilter.cpp 536: cupsRasterOpen failed, fd = 0
D [18/Jul/2012:14:52:25 -0400] [Job 43] prnt/backend/hp.c 839: ERROR: null print job total=0


So it looks like from kwrite it’s sending a null page. What could be going wrong?

Are you running KDE? What version? Can you print from another KDE app, like okular?

It may be a problem with the KDE printing system, or it’s interaction with cups. Can you print to another device (like PDF) from kwrite’s print dialog?

Did you try with a new user? Or a KDE update? Or a cups update? Or an hplip update?

(So many questions, so little time…)

Thanks for replying. After much research I discovered it was only kwrite that couldn’t print, but then a day later it magically could! So now I have no idea what was causing it and if any of my reinstalls fixed it or if it just was some weird hiccup.