HPLIP scan plugin problems

Hi,

I’m trying to install HP LaserJet Pro MFP M127fn. The HPLIP installation and printing itself works but I cannot get the scanning to work because the HP plugin installer fails.

First I used HPLIP from the repos (3.18.6 I think), and now I’m trying with the newest version from the HP website (3.19.3). The problem is the same with both versions.

This is what happens when I run the plugin installer:

hkt@desktop:~> hp-plugin -i      

**HP Linux Imaging and Printing System (ver. 3.19.3)**
**Plugin Download and Install Utility ver. 2.1**

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


**HP Linux Imaging and Printing System (ver. 3.19.3)**
**Plugin Download and Install Utility ver. 2.1**

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


-----------------------------------------
| PLUG-IN INSTALLATION FOR HPLIP 3.19.3 |
-----------------------------------------

  Option      Description                                        
  ----------  --------------------------------------------------
  d           Download plug-in from HP (recommended)             
  p           Specify a path to the plug-in (advanced)           
  q           Quit hp-plugin (skip installation)                 

**Enter option (d=download*, p=specify path, q=quit) ? **d

-------------------
| DOWNLOAD PLUGIN |
-------------------

Checking for network connection...
Downloading plug-in from:  
Downloading plug-in: \                                                                                                                                                      ] 0% Receiving digital
 keys: /usr/bin/gpg --homedir /home/hkt/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
()
**error: Unable to recieve key from keyserver**
**Do you still want to install the plug-in? (y=yes, n=no*, q=quit) ? **y

----------------------
| INSTALLING PLUG-IN |
----------------------

Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.3 Plugin Self Extracting Archive.Extraction failed.
**error: Python gobject/dbus may be not installed**
/
gzip: stdout: Broken pipe
  
Done.
hkt@desktop:~> 


I can’t find any packages that are missing going by that error message, also the HPLIP installer checks for dependencies and does not complain about anything.

Use the YaST > Hardware > Scanner module once. After that you should be fine with xsane, skanlite ( and the HP scan function ).

I just got this working by downloading the plugin file from HPLIP website and running it manually.

At least from the HP Toolbox -> Scan it works now.

Thanks