HPLIP nightmare in 64bit 11.1

I recently bought an HP OfficeJet 6500 AIO printer. Since the printer has ethernet connectivity, I have managed to setup the printer with the 32bit openSuSE 11.2, 11.3 machines I have in my network. However, the 64bit 11.1 is another beast. I cannot make the printer work.
The default and updated from officials repos hplip does not contain the PPD file for the printer/scanner/fax.
I added the “Printing” repository (Index of /repositories/Printing/openSUSE_11.1) and downloaded the 64bit versions of hplip, hplip-hpijs packages. Now, the issues:

  1. hp-setup does not run with “Segmentation fault” error!
  2. Although I can see the printer, setup and modify it’s configuration, cups cannot print, not even a test page.
    The errors I have are:
Unable to execute /usr/lib64/cups/filter/hpcups: No such file or directory

Regarding the 1st error, I “solved” it by using the hplip-qt3 package from KDE_3 repository. And when I used that version of hplip, (3.10.9-4.2, instead of the 3.10.9-31.1 of the Printing repository), I had no more filter related problems (foomatic etc).
For the second one, it is obvious that the problem is related to the location of the 64bit filters.
The /var/log/cups/error.log has the following lines:

I [13/Jan/2011:20:50:52 +0200] [Job 60] Started filter /usr/lib64/cups/filter/pstops (PID 30039)
I [13/Jan/2011:20:50:52 +0200] [Job 60] Started filter /usr/lib64/cups/filter/pstoraster (PID 30040)
E [13/Jan/2011:20:50:52 +0200] Unable to execute /usr/lib64/cups/filter/hpcups: No such file or directory
E [13/Jan/2011:20:50:52 +0200] [Job 60] Unable to start filter "hpcups" - No such file or directory.
I [13/Jan/2011:20:51:00 +0200] All jobs on "hp" were purged by "root".

Should I just use the original hplip and add the ppd files that I need?

It seems like a good plan, specially if it was working before.

But note that 11.1 is not supported anymore, so you may not find the packman packages for hplip.
You may want to consider an upgrade, if not to 11.3 then at least 11.2 which became very stable IMO.

That said, 11.3 64-bit with hplip from the DVD install work without issues with a new hp multifunction printer at the office.

Jus a minor point, I don’t think Packman package hplip for ANY openSUSE version any more. There are various packagers packaging hlpip for openSUSE but Packman packagers are no longer one. I do not recall when they stopped, but they no longer have any hplip on their web site so it appears they definitely stopped.

Still, one can find many hplip packages if one searches Webpin or software.opensuse.org

That would be my recommendation also.

Still, having expressed my agreement, I do note that the openSUSE community is attempting to create a long term support (LTS) version of openSUSE in a project called “Evergreen” and openSUSE-11.1 is the distro version they have chosen. The intention is to make this more server based than desktop based, but I would think (hope ? ) that for a server hplip would be required and hence hplip may be one of the applications with a better chance of the Evergreen project trying to keep available for 11.1 ( … and my having typed that, I still recommend an update to 11.3 if feasible).

11.3 out of support? I am not so sure, I mean I had a number of updates just today.
I am not willing to upgrade to 11.2 or 11.3 because KDE 4 still misses extremely important to me functionality of KDE 3.
Anyway, the problem solved with the creation of links from the /usr/lib64 to /usr/lib files. Still, I believe that this is a bug. Anyway, I will lock those files and in case I will upgrade, we will see them.