HPLIP installation on Suse 11.1 causes KDE GUI to fail

Yesterday I installed hplip on this PC, followed the CLI instructions and printed the test page - all without rebooting.

Today I fired up, logged in and the GUI started to load, but just hangs. None of the desktop shortcuts work. I could bring up the HP console from the icon in the system tray. Nothing else. :frowning:

CTRL+ALT+DEL, and then logout to retry - same problem. I used the HP icon to quit the application (albeit with slow response), and re-logged in - same issue.

To get here I have had to log in using the ICEWM option on the graphical login screen. I tried to uninstall hplip using

su -c “make uninstall”

and

su -c “rm -rf /usr/share/hplip”

  • but KDE still fails to load.

Any hints and tips?

Clint
OpenSuse 11.1
KDE4.1 (normally)

Been playing some more, and right click on the “system tray” works on the eth0 icon (HP icon is no longer there, because I closed this, and tried the uninstall).

After a logout request (CTRL+ALT+DEL) there is a pause and some of the windows for the icons that I click appear - looks a bit like a process is hanging in the startup/login cycle.

Any idea where I would look to resolve this?

Hi Clint -

I’m a technician who works on the HPLIP team. I have a few questions regarding your SuSE11.1 issue. You say that you followed the CLI install instructions. Did you use the auto-installer, or did you manually install HPLIP?

I’m currently trying to reproduce the situation you’ve described so that we can investigate it further.

It sounds like you were able to successfully install HPLIP on your system, but you lost functionality after the install. Did the install go smoothly, or were there any error messages displayed during the install?

Could you elaborate on “KDE failed to load”? Were you able to log into your system, but without GUI support?

For future reference, if you need assistance with HPLIP, please visit hplipopensource.com. Our “get help” tab on the left hand side provides resources for questions about HPLIP.

Thanks for the response. I used the ‘auto installer’ following the instructions at…

HP Linux Imaging and Printing

  • I typed sh hplip-3.9.4b.run

It all seemed to progress OK. It got through to the final stage, and there were 2 options…

  1. unplug the USB cable, press enter, re-plug the cable
  2. reboot the PC

I used option 1, and printed the test page fine.

I don’t recall any warning/error messages that came up.

Then I cleanly shut down the PC. Next evening grub loaded (I dual boot with XP), selected the usual Suse option and it booted to the login screen. When I then enter my username/password the GUI (KDE) starts to load. There is usually a small bouncing cursor (“hour glass”) - now during the load, the bouncing cursor leaves ‘white’ behind - the graphics are not re-drawing.

The mouse pointer moves round the screen, but the desktop icons do not respond - neither does the ‘start’ menu in the lower left. The only response from mouse input that I could get was right clicking on the system tray (lower right) and the ETH0 dialogue box would come up.

pressing num-lock illuminates the keyboard light - showing that the system is alive but CTRL+ALT+DEL is the only way that I can get any response. I can then select ‘logout’.

From the graphical login screen I can select ‘failsafe’ which boots into a console only mode. I can also select ICEWM to launch into a GUI - from where I did

su -c “make uninstall”

and posted my initial messages below - but I’d really like KDE back !

The su -c “make uninstall” seemed to work - came up with messages about removing directories and files etc, but had now effect on enabling KDE to load.

[should I stop posting here, and post on the HP Linux Imaging and Printing page?]

Try deleting the .kde config file in your home directory or try adding a new user and see if you get a kde login.
BTW, the hplip driver options ae part of the suse package. When you install the printer in yast, choose the hplip ppd instead of one of the others.

When I say ‘suse package’, I mean you can install it via yast>software.
Unless you want the latest version, it’s probably best to install it via yast than to manually install from the installer file.
Once installed, Set the printer up in yast and choose the hplip driver.

Clint Weston wrote:

> - I typed sh hplip-3.9.4b.run

The only versions from HP that I’ve found to work is 2.8.7, all others fail
during make. I reported the problem when 2.8.6 was the latest version and
2.8.7 came out shortly afterwards with a fix. Unfortunately, later versions
went back to their old, bad ways. I’ve since reported these later failures
to HP.


Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
“I wear the cheese. It does not wear me.”

I tried to access via another existing user, and a brand new one - same problem.

On the new test user, I did manage to bring up top (blindly Alt+f2, konsole, <enter>…brought up the terminal then I could enter top)

A process called ‘plasma’ was using >70% CPU

Not sure if this is relevant - but to me, it looks like something is hogging the CPU

Last night, I accessed YaST from the IceWM login and updated KDE4 to the most recent version available.

Re-login seemed to show 4.3 (?!) - this then launched, but all the screen icons were very large (about twice normal size).

The task bar was also similarly corrupted, but the applications worked fine.

The icon/desktop layout issue made me ‘downgrade’ to KDE4.1 - but the problem with lack of response re-occured :frowning:

Looks like some issue with the KDE installation, rather than HPLIP - but something seems to have been corrupted during the HPLIP install.

Re-login seemed to show 4.3 (?!) -

If unintended, I’m guessing you have factory repo enabled.

Looks like some issue with the KDE installation, rather than HPLIP - but something seems to have been corrupted during the HPLIP install.

This does look like a KDE4.X installation problem. I’m not sure what to advise, but to start with can you post your repo details:

zypper lr --details

Might be a good idea to start a new thread with suitable heading to help catch the attention of others who can help.