HP1020 will not work with hplip

Hi all,

Using 11.2 64bit gnome. I have a HP1020 USB laser printer that is being recognized by hplip, but cannot connect. I keep refreshing, restarting the printer, restarted the computer to no avail.
I do have a network HP2025 laser that is working properly with the same hplip.

Any ideas?

Thanks

Heeter

Have you tried the CUPS web interface?
CUPS - Explained - openSUSE Forums

No I haven’t.

Thanks for the link.

Will get back to confirm later.

Thanks

Heeter

Recommend you use this method: HowTo Install a HP LaserJet 1020 printer in Suse 10.x, 11.x

Thanks Swerdna & Caf,

And a Merry Christmas to you both, many good wishes for the new year!

Heeter

Friend.
Please let us know if and when you have any kind of result. Others may benefit from finding out what worked for you. Thanks:)

Will Do,

I will be back at the office on Tuesday (that is where this workstation is) Will report back when I do work on it.

Thanks

Heeter

Hi all,

Well I tried the Swerdna fix, to no avail.

I see it listed in CUPS, but cannot get it to print a test page.

Any other ideas?

Thanks all.

Heeter

If it’s listed it should work.
Did you add yourself to group lp ?

Then use the admin mode to login to CUPS and setup the printer

Hey Caf,

Thanks that fixed it.

Just deleted it from cups and reinstalled it. And added myself to the group.

Thanks a million, Caf.

Heeter

Dude, that’s what we are here for;)

Greetings Swerdna, Caf, and Heeter.

Just wanted to say thanks to you all for the help with my (clunky) HP 1020. It’s been a couple days of hair pulling to make this work, but Swerdna’s tutorial (and remembering to go back to YAST to make sure that I had make, gcc, and kernel-source installed!) finally did the trick.

best wishes for the new year.