HP WiFi toggle button not working

My HP Probook 4540s has two buttons for networking, one for Wi-Fi and one for Internet.
I’m mostly curious about the Wi-Fi button. I remember that when I bought the laptop, it would work out of the box and toggle wifi on or off. Now when I press it nothing happens.
So I ran showkey --scancodes and again when I pressed the button no code appeared (the other button works just fine).

Is there any way I can see if the button actually works from an electronic point of view? I know it can’t simply stop working (the laptop is pretty new), but I just want to get the hardware issue out of the way or return the machine for repair.

Have you tried navigating to the plasma-nm and trying the following:

  1. Right-click on the plasma-nm and select Network Management Settings
  2. Click on the Wireles tab
  3. On the left column and select Keyboard Shortcut
  4. Press your Wifi button on the “none” settings to assign your button

I’m not sure that the button will be part of the keyboard infrastructure. Instead, it is connected to the wireless hardware. You can observe it functionality via ‘rfkill’ though.

rfkill list

HP Probooks are usually openSUSE friendly. That switch is an essentially a hard wired on/off switch and the shortcut should work.

The shortcut assignment didn’t work (basically I get no input from the button) and rfkill list shows:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

On Tue 21 Jan 2014 11:16:01 PM CST, bogdanc2011 wrote:

The shortcut assignment didn’t work (basically I get no input from the
button) and rfkill list shows:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Hi
I have a ProBook 4430s (this machine) both buttons work fine to start
the browser and enable/disable wifi and bluetooth;


rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Is the laptop pattern installed? patterns-openSUSE-laptop, since I run
GNOME I also have patterns-openSUSE-gnome_laptop installed.


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.6-4-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Is the laptop pattern installed?

It wasn’t. But I did and also did a reboot… still no input.

Just a guess on my part: Perhaps you need to load the hp-wmi module (hotkey support)?

modprobe hp-wmi

If that works then instructions can be given on how to load it on boot.

For the record, I actually found that it wasn’t playing nicely with my wireless hardware after I installed openSUSE 13.1, and so I have blacklisted it. (My laptop is a Compaq 6710b.)

Just a guess on my part: Perhaps you need to load the hp-wmi module (hotkey support)?

When I run modprobe hp-wmi nothing is displayed.

Nothing will be returned from the console, but you can then check if the module is loaded with

lsmod|grep wmi

Does it bring the wireless key to life? If not, just remove it again with

modprobe -r hp-wmi

or reboot.

The first command returns this

hp_wmi 14062 0
sparse_keymap 13948 1 hp_wmi
rfkill 26772 5 bluetooth,hp_wmi,cfg80211
wmi 19177 1 hp_wmi

after removing the module and rebooting (with the second command).
But the button still does nothing.
The curious thing is that the other button, which opens up a new browser window, is working and its LED is white, as opposed to the wifi button which is yellow.

Did you install the “kernel-firmware” package? Install it, reboot your laptop and try the wifi button.

Follow Up

Navigate to Yast -->Network Devices --Network Settings to to set up your wireless card.
Next, install and use rfkill and unblock “0” (that’s zero without the quotes).

Use this link as a reference http://wireless.kernel.org/en/users/Documentation/rfkill

rfkill --help
Usage: rfkill [options] command
Options:
–version show version (0.5)
Commands:
help
event
list [IDENTIFIER]
block IDENTIFIER
unblock IDENTIFIER
where IDENTIFIER is the index no. of an rfkill switch or one of:
<idx> all wifi wlan bluetooth uwb ultrawideband wimax wwan gps fm nfc

That should do it.

Update

@bogdanc2011

A possible fix has been found.

I decided to install Windows afterall. The button works there and its LED turns white. So it’s not a hardware issue, although I do need to download a driver from HP’s website.