HP Printer stopped working

Have an HP f2200 with HPLIP & HPLIP-HPJIS drivers installed that came with 11.2 CD

This printer has been working flawlessly for me for many months. I had no problem getting it going. Plugged it in - loaded it up in Yast and it has worked ever since.

However, today I opened up the HP device manager to clean the cartridges. I clicked on the clean stage one option and the cartridge went through some motions but it did not load any paper like it was supposed to.

I didn’t think anything of it but when I tried to print something the queue manager status stayed as pending nothing ever printed. I palyed around a bit but coudn’t get anything to print.

In frustration, I deleted the printer in yast and tried reinstalling it from scratch. After detected and installed I tried to print a test page from yast. The system tray notifiction pops up and advised job sent to printer and then that job is completed. However, nothing printed. Checking print queue it shows as print stopped.
I click the OK window in Yast and it says /usr/lib/cups/filter/hpcups failed

I thought it might be the printer so I plugged it into a windows computer but it worked without problem.
I tried changing cables and USB ports but did not help.

It seems something has become corrupted in a config file somewhere in Opensuse.

What would I need to do to remove all previous settings and start from scratch - as I never had any problem getting it to work previously?

Any help would be very much appreciated.

should mention that there is still communication with the printer as I can align cartridges using the HP config device.

I gave up recently and setup mine via cups web interface. http://localhost:631/
You have to login with root
Delete and printers in there and set up a new one.
You leave the HP drivers as they are

Works for me mostly, some applications seem to cause my printer to just stop and the light starts blinking.
IIRC it was gwenview that did it recently, trying to print a image.

Pasted the image to office and it worked fine

have solved it by doing the following

delete the printer in yast.

Log in as root and run hp-setup

log back in as user and the printer is up and running again.

The problem with this printer it seems is that trying to run any cartridge maintenance from hp config corrupts the printer and it needs to be uninstalled again and reinstalled as root using above.

pain in the backside really. have to run cartridge maintenance from my wife’s windows notebook in the future

does seem temperamental - I usually have trouble trying to print from kpdf