HP printer problem

Under Opensuse 12.4 + KDE 4.8.5. My printer HP PSC 1510 seems to work fine (can print test page). I reinstalled the printer in cups but job fails to print. The hp device manager seems messed up. It was working a few days ago. Now I cannot communicate with the printer. Here is what I get in console when trying to start the hp dm :

HP Linux Imaging and Printing System (ver. 3.12.4) HP Device Manager ver. 15.0  

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP This software comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to distribute it under certain conditions. See COPYING file for more details.  

warning: Reportlab not installed. Fax coverpages disabled. warning: Please install version 2.0+ of Reportlab for coverpage support. 

Traceback (most recent call last):   
File "/usr/bin/hp-toolbox", line 257, in  <module>
  toolbox = DevMgr5(__version__, device_uri,  None)   
File "/usr/share/hplip/ui4/devmgr5.py", line 204, in __init__    
  if not utils.Is_HPLIP_older_version( installed_version,  self.user_settings.latest_available_version):   
File "/usr/share/hplip/base/utils.py", line 1795, in Is_HPLIP_older_version   
  if(int(installed_array cnt ]) < int(available_array cnt ])): 
ValueError: invalid literal for int() with base 10: "11 Public Release')"


I can read in another thread about problem with hplip upgrade. Could it be related to this one ? Or is it different ?

Under Opensuse 12.4
Which seems unlikely

Can you please check again

Yes of course 12.2 :

openSUSE 12.2 (x86_64)
VERSION = 12.2

On 2012-12-19 11:16, bzidler wrote:

> I can read in another thread about problem with hplip upgrade. Could
> it be related to this one ? Or is it different ?

It certainly looks a problem of that third party (HP) software. As you
say you did an update, revert it.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

I can read in another thread about problem with hplip upgrade
This is unrelated

Try going here:

CUPS web interface and login as admin with
and your root password

remove any existing printers
and add back your printer, but take not to be sure it’s the CUPS control version in the list offered

I reinstalled cups 1.5.3 and hplip, recreated a printadmin group and added it in cupsd.conf. Also removed part of the upgrade section in ~/.hplip/hplip.conf, letting me get the hp-toolbox working again. So now I can see the printer and manage it again through cups, and can see a job in the job queue, but still no printing. No error signaled in /var/log/cups/error_log.

On the job tab in cups :

▼ ID ▼    Name    User    Size    Pages    State    Control
HP_PSC_1500_series-85      Unknown      Withheld      1k      1      processing since Thu 20 Dec 2012 11:00:52 GMT "Processing page 1..."

orion:~ > lpq
HP_PSC_1500_series is ready and printing
Rank    Owner   Job     File(s)                         Total Size
active  (null)  85      untitled                        1024 bytes

On 2012-12-20 12:36, bzidler wrote:
> I reinstalled cups 1.5.3 and hplip, recreated a printadmin group and

IIRC, there is a wiki page (perhaps on the old wiki, I’m unsure) about
how to completely remove CUPS. Reinstalling the packages do not suffice
some times, because the configuration files persist.

(my current internet connection is capped at 500MB/month, or I’d search
and give you the exact link)

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

What document are you printing?
Is it a LO document? Or are you trying to print a test page.
Have you tried some different documents Eg a .pdf

I have tried several types of documents. Image, pdf and ascii text. It does not make any difference. I think I will leave this weird problem for a while, going away for Christmas. Thanks for your help.

personally, I find installing the printer via yast gives you less opportunity to mess things up.

You could also try switching to the printing repo. That has newer versions of cups, hplip etc.


Don’t know if it will help but could be worth a shot.

Thanks, but I have already tried all this as well. And it is true that with an hp printer you have the choice between hp-toolbox, yast and cups, all conflicting between them. Can drive you insane. I will tell you when I find the solution. But it’s not sure I will, because the printer can suddenly work again one day, without obvious reason. As it stopped working without any alert :slight_smile:

And as I said 15 minutes ago, the printer can work again. As a last attempt before giving up, I reupgraded cups again, from obs://build.opensuse.org/Printing, changing the cupsd.conf for the new one, restarted the cups service (systemctl restart cups.service) and printer prints again ! And I am really sorry, but after all these tests and changes, I have no idea what was wrong in the first place. Anyway, thanks for all your advices, and merry Christmas to all.


Hi there,

I was having the exact same issue with hplip. Strange, but I was also having a similar issue with Kubuntu using their hplip software.

What I did do solve it was downloading the package right from HP… So, go here: HP Linux Imaging and Printing and click on the link that says - Download HPLIP.

Then, save the file. Now, open a terminal and chmod +x the file - chmod +x hplip-3.12.11.run

Now, as a NORMAL user (No su - or su - c or sudo), run the package - ./hplip-3.12.11.run

It will go though and check packages and what not, then ask for your root password. Enter that and accept all the defaults… Now, you will come to an option to remove/install or overwrite. I did overwrite, but you might want to try remove/install as it will remove the current rpm and install the new package. However, I did overwrite and its working as it should.

Then, select the restart - the system will reboot and you will be good to go.

Hope this helps!


I’m having a problem with this too. This started with 12.2. I have two printers. Both are HP’s and both are connected via tcp/ip. I first attempted to install and manage with the cups management. http://localhost:631/printers/ It was more painful than I recall. I just could not seem to get it working correctly. Just about the time I would think I had it all working fine, it would not print again. I finally dug a little deeper.

it was always showing as the printer being disabled. Cups would not let me re-enable it via the web page. I finally found that at least with the Yast admin I can enable the printer. I still haven’t figured this out. I’m almost certain it is disabled after every reboot. I believe it is a bug, but don’t know if it is a bug with HP’s drivers, cups or Opensuse. I’m fairly certain it is not Opensuse. I’ve others with other flavors have the same issue. I’m guessing this is a cups issue, but who knows.