HP printer fails - 13.2 and TW

I’ve been trying to print a small file from TW to my HP 6500 AIO WiFi printer with no luck, so I tried it from this 13.2 system (upgraded from 13.1 and fully updated) - same problem. Other systems on the LAN (13.1 and Win7) print OK.

The CUPS status page says the printer is paused, accepting jobs, not shared, and the state is “/usr/lib/cups/backend/hp failed”. If I resume the printer, I get the popups saying a job has started and finished, but no action on the printer itself and it pauses again with the file still queued. Looking at the files in /var/log/cups I see no errors, only normal start/finish entries.

What next?

You are not alone: Same here (after software update two days ago).

Jan Christian

Now you are alone:
I logged in as root, and did reset all passwords for the CUPS Users.
I suspect that it was kdewallet, that I had dropped, that was the
source of the trouble, but I cannot prove it.

Best regards,
Jan Christian

There is a pair of drivers for this printer, a simpler and a more complex one. Have you tried both?

My problem is solved, but not by logic. The only change applied to this 13.2 system was the patch to ‘file’, and it works?!?!

However in the meantime I had updated the firmware in the WiFi router (ASUS RT-AC66U), so I am thinking it was a networking problem. The failing systems were both WiFi connected, while the working ones were hard-wired.

So maybe not an openSUSE problem after all.