HP Printer Driver

After installing my new HP DeskJet D2545 printer with drivers from HP for Linux SuSe, everything worked out just fine. Printer works, no problems. :slight_smile:

However, every time I boot up I get a New Hardware Notice for a scanner… well I don’t have a scanner hooked up and the printer has no scanning features.

Why am I get a New Hardware Notice for a scanner? :confused:

I need to add that printer is connected to a USB port.

{Could not edit first post}

With the printer connected as you usually do, open a console and try

hwinfo --scanner

(You may have to be logged in as root; I’m not sure)

If you get a response, it will either explain the problem or you can post it here for an explanation.

If you don’t get a response, then it may be a bug in KDE; check the bug reports and, if necessary, post one.

Opened a console, logged as SU, hwinfo --scanner did not display anything.

But just for kicks, I tried hwinfo --printer to see what I would get;

20: USB 00.0: 10900 Printer
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_3f0_1e04_TH88Q1122D055K_if0
Unique ID: Mwf_.Xxdv7MsvlMD
Parent ID: 2XnU.45mwbXWbMY8
SysFS ID: /devices/pci0000:00/0000:00:13.5/usb5/5-3/5-3:1.0
SysFS BusID: 5-3:1.0
Hardware Class: printer
Model: “HP Deskjet D2500 series”
Hotplug: USB
Vendor: usb 0x03f0 “HP”
Device: usb 0x1e04 “Deskjet D2500 series”
Revision: “1.00”
Serial ID: “TH88Q1122D055K”
Speed: 480 Mbps
Module Alias: “usb:v03F0p1E04d0100dc00dsc00dp00ic07isc01ip02”
Driver Info #0:
Driver Status: usblp is active
Driver Activation Cmd: “modprobe usblp”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #18 (Hub)

Looks good, I’ll check the KDE bug reports and see what I can find.

Thanks :slight_smile: