HP Print Server with OpenSuse 11.1

I got a page not found error when typing the ip address in the browser.

I assume you have this printing through a Windows Machine. Have you tried
just sharing it on the Windows machine and then printing to it via a network
print to the Windows machine via Samba.

I could not get the shared printer on vista to work.

I should add:
On the Opensuse computer, I can view the shared user folders, and public folders that are on vista. However, vista does not display the shared folders that are on Opensuse. From the vista computer, Mcafee recognizes that the Opensuse computer is there, but can’t scan it because Mcafee doesn’t make software for real operating systems. I can ping the Opensuse computer from a command prompt in vista.

mwgraham wrote:
> I should add:
> On the Opensuse computer, I can view the shared user folders, and
> public folders that are on vista. However, vista does not display the
> shared folders that are on Opensuse. From the vista computer, Mcafee
> recognizes that the Opensuse computer is there, but can’t scan it
> because Mcafee doesn’t make software for real operating systems. I can
> ping the Opensuse computer from a command prompt in vista.

Networking on Vista is completely borked. My wife’s Vista machine could not see
the shared folders or printers on an XP desktop; however, I was able to mount
the XP’s printer on openSUSE, and share it. The Vista laptop could then print on
that device.

On Wed May 20 2009 04:06 pm, mwgraham wrote:

>
> mwgraham;1989043 Wrote:
>> I assume you have this printing through a Windows Machine. Have you
>> tried
>> just sharing it on the Windows machine and then printing to it via a
>> network
>> print to the Windows machine via Samba.
>>
>> I could not get the shared printer on vista to work.
Could you see the printer on VISTA from XP?

>
> I should add:
> On the Opensuse computer, I can view the shared user folders, and
> public folders that are on vista. However, vista does not display the
> shared folders that are on Opensuse. From the vista computer, Mcafee
> recognizes that the Opensuse computer is there, but can’t scan it
> because Mcafee doesn’t make software for real operating systems. I can
> ping the Opensuse computer from a command prompt in vista.
>
>
mwgraham;

While you’re testing disable the firewalls on both VISTA and Opensuse.

  1. On Opensuse make sure the following ports are open on the firewall.
    TCP: 135,139,445
    UDP: 137,138
    You also need to enable broadcasts. If you are behind a router you can also
    add your local lan to the trusted networks.
  2. Be sure to add Samba users on OpenSuse with:

su
smbpasswd -a <username>

The above username must be a valid Linux user, but the password you assign can
differ.
3. Make sure the workgroup is the same on both VISTA and Opensuse.

  1. McAfee does not understand Linux, however, this should not be a problem.
    Though you may need to juggle around some of it’s settings. I have used the
    McAfee AV but normally disable the Firewall and never took the time to really
    look into it. (We’re behind a router and no ports are forwarded; laptops that
    might roam around usually have AVG, that firewall seems more configurable
    than McAfee’s. )
  2. I would try to install the shared printer directly in CUPS:
    http://localhost:631/
    or if you are using KDE with KDE’s “Print Manager”.

Be sure to read the HowTo’s on Swerdna’s site. If you are still having
problems I would suggest a new thread, since this is really a different
problem. If you do post on this be sure to include the [global] section
of /etc/samba/smb.conf; you can substitute values for any critical
information such as public IP’s etc.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On Wed May 20 2009 05:18 pm, PV wrote:

> On Wed May 20 2009 04:06 pm, mwgraham wrote:
>
<snip>
>
> Be sure to read the HowTo’s on Swerdna’s site. If you are still having
> problems I would suggest a new thread
in the Network forum,
> since this is really a different problem.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

From the vista box, try the printer ipaddress again. If you get the server web page, everything’s fine and it should work in linux.
Since you now know the ipaddress from vista and that it works, go back to linux and try pinging the ipaddress.
If there is nothing, you have a problem with your network setup.
Check your linux network setup, especially for gateway/router address and that it it on the same network.
BTW, the print server uses port 9100 for printing.

Thinking a bit more about it, I think you have a network setup problem. Is the wireless network wired into the main network anywhere, or is it all completely wireless?
If all completely wireless, look at your suse wireless setup.
If it is wired through a router or access point, you need to add the routing information to your network setup.

The router is a combination wireless and wired router so the wireless laptop and print server connect to the router that the Opensuse computer is connected to.

I found this on the HPLIP Launchpad forums:

I figured out that the HP 2101nw is not a print server but a port extender.
The USB communication is transferred to a virtual port.
All processing happens on the main computer.

Any idea how to set Linux up to do this?

Just had a quick look at the 2101nw user guide.
Not an expert on this, but my gut feel tells me you need to do something like the following:
If you installed it correctly and connected it to the network as described in the guide, you should be able to ping the 2101 using its ip address.
If this works, you need to set up tcp/ip printing to the 2101 ip address.
Now choose the printer model.
HHLIP will only really work if its on a jet direct connection or direct connection.
If you search the forum, there must be threads on tcp/ip printer setups.

OK assuming you can ping the 2101, here’s how you do it:
Open yast2>printers
Add local printer
Choose network printer
Choose print directly to the printer
other printer (URI)
Enter: http://ipddress
Enter printer details

When you get to the setup page again, enter the printer model and choose the driver.

(Works for me to both jet direct and other pcs with tcp printers shared.)

OK assuming you can ping the 2101, here’s how you do it:
Open yast2>printers
Add local printer
Choose network printer
Choose print directly to the printer
other printer (URI)
Enter: http://ipddress
Enter printer details

When you get to the setup page again, enter the printer model and choose the driver.

I was able to follow the steps above to get the printer printing through the vista’s shared printer. Seems backwards to be using the laptop as the “print server”. Hopefully HP will get the 2101nw print server working with HPLIP soon.

Thanks for the help

Glad you got something going.
Have a look at these 2 posts:
HP Printer ok but no pages printing - NOVELL FORUMS
and
Cool Solutions: Installing a All-In-One HP Printer on SLED 10 SP1
The basics should work.
Also, it seems you need to disconnect the usb connection.