HP Photosmart Premium stopped working using 12.2 with error /usr/lib/cups/filter/hpcups failed

Hi all,

I have a HP Photosmart Premium printer that is connected to a laptop (Samsung R580) running OpenSUSE 12.1 KDE x64. When I try to print something, it seems to accept the job, but nothing comes out the printer. The error message that comes up in the CUPS admin panel is: /usr/lib/cups/filter/hpcups failed. On Pastebin, here the the CUPS error log: E [07/Sep/2012:20:25:55 +0100] Browsing=1 E [07/Sep/2012:20:25:55 +0100] Browse - Pastebin.com. The printer is connected wirelessly, by the way.

Please give me an answer ASAP :slight_smile:


In your title it says “12.2”. In the tread it says “12.1”. What is correct?

Sorry about the confusion, I’m definitely using 12.2, I upgraded a few weeks ago. It also says 12.2 in the release notes section in YaST, so it must be 12.2. :slight_smile:

Start hp-toolbox, search the interface a bit and restart the printer. It will ask you for the root password.
This sometimes happens if the printjob is damaged.

This is interesting - the HPLIP interface says that the print jobs are all completed, even though they are not. I’m not sure what’s wrong to be honest, it worked fine for the past 2-3 weeks, but now it isn’t.

Open a terminal window, and do

lpstat -t

post output here, between CODE tags.

scheduler is running
no system default destination
device for HP_Photosmart_Premium_C309g-m: socket://
HP_Photosmart_Premium_C309g-m accepting requests since Thu 20 Sep 2012 17:35:43 BST
printer HP_Photosmart_Premium_C309g-m is idle.  enabled since Thu 20 Sep 2012 17:35:43 BST
        /usr/lib/cups/filter/hpcups failed

Here is the output.

May not relate to your problem, but…

In a recent 12.1 install, an HP printer was shown as “stopped” in hp-setup. Trying to start it would give me an error message about cups, asking “did you try adding the user to the sys group?” or words to that effect.

Well, doing it solved the problem, the printer works normally now. This is new for me, before I just had to add the user to the lp group.

I have added myself to the sys and lp groups, but it still doesn’t work. It comes up with the same error in the CUPS web admin panel.

Remove the printer through Yast, then readd it through

su -c 'hp-setup'

Please also show output of

cupsdisable HP_Photosmart_Premium_C309g-m && cupsenable HP_Photosmart_Premium_C309g-m && lpstat -t

Here is the output from the second command:

scheduler is running
no system default destination
device for Photosmart_Premium_C309g-m: hp:/net/Photosmart_Premium_C309g-m?ip=
Photosmart_Premium_C309g-m accepting requests since Fri 21 Sep 2012 16:42:35 BST
printer Photosmart_Premium_C309g-m is idle.  enabled since Fri 21 Sep 2012 16:42:35 BST
Photosmart_Premium_C309g-m-27 jack          18947072   Fri 21 Sep 2012 16:40:15 BST

I have also removed and added the printer again using YaST and hp-setup, as requested.

Upgraded to 12.2 a day ago. Experienced problems with Intellegacy graphics (another thread - turns out my three year old chipset is no longer supported), slow boot, and just noticed today, network printing. Kept getting a connection error on each printing attempt.

I spent the afternoon fussing with hplip trying to re-establish printing to a HP wifi network printer (should have taken a half hour, at the most).

Finally had to upgrade hplip to 3.12.9 off the hplipopensource.com site, along with updating a bunch of dependencies (the script actually took care of that).

Then hplip insisted on re-configuring the printer, instead of just connecting to it, and put in the wrong subnet even after I specified the correct one. So the printer had to be carried over to a Windows system to be configured properly.

Finally after a couple attempts, hp-setup worked and we are again printing.

Not saying any of this is relevant to this thread other than as a heads-up to other hplip users.

Really wish the SUSE Release Notes or Known Problems report (as I have seen on some other distros), mentioned some of these third-party gotchas (and in sufficient detail to be useful, like on the unsupported graphics). The Intel issue definitely was known prior to the 12.2 release. The SUSE Release Notes seem very sparse to me.