HP Photosmart C6280 will not work on Opensuse 11

Anyone got a Photosmart printer to work on the new Opensuse 11?
I have installed the hplip packages, but still can’t make it to work.
I have the printer accessible through network only.
Any can shed some light on this?

I’m using a HP Photosmart C5180.

for Gnome: (printer connected through eth to router)
Computer>Applications tab>More Applications button>in left pane click System>in right pane click HP Toolbox (HP Device Manager)
HP Toolbox (HP Device Manager) opens: click Setup Device button and give it some time to find the AIO (ALL In One). If it can’t find it,hit the button ‘find manually’ and enter the IP for it.

If you don’t know the IP, is there a button on the AIO called ‘settings’?
If yes use that to reveal the network settings which will show you the IP it has. (don’t know the 6280 but the 5180 has this feature)

See to it you also have libaio installed if you also want to use the scanner with xsane.

I have an HP Photosmart C6280 and installed it in openSUSE this morning. (After making many mistakes last night, then going to bed, sleeping on it.) I suggest you try this.

On your HP Photosmart C6280 printer panel, push the setup button, then select Network>View Network Settings>Display Wired Summary. Note the IP Address. In my case it was

Back to the computer.

I’m in KDE 4.

See that you have the necessary drivers installed. I don’t do command line, so I checked in Yast.
Computer>Install Software
search hp
select hplip and hplip-hpijs and install these packages and dependencies, then exit Yast.

To add the printer I went this route:

Menu>Applications>Utilities>Manage Printing

That brings up CUPS.

Add Printer.

Enter name, location, and description then select “continue”

Select AppSocket/HPJetDirect then “continue”

Enter “socket://(the IP address from your printer above)” in my case in looks like this, “socket://” then “continue”

Select “HP” and “continue”

Select “Photosmart C6100” and “Modify Printer”

Username: root
Password: (enter your password)

That worked for me. One hiccup I encountered was when it asked for my username and password I used my login. I was denied. Then I used root, and was denied because Yast was still open. After closing all other programs CUPS accepted my password.

I left all the other settings at the default from install of openSUSE 11.

Try a test print. I’m new to openSUSE, so I can’t troubleshoot, but the procedure above worked for me.

I haven’t tried scanning yet, I’ve never done scanning in Linux, only been using Linux as my primary OS since January 2008. With the HP C6280 there is always the option to scan to a memory card if the computer scanning software isn’t working, or properly installed and configured.

Best wishes.

so you have elected a wireless link from the printer to the computer?

thanks for the post. i too have the same c6100 series and had it perfectly setup in 10.3 - couldn’t figure out why i wasn’t see the photosmart c6100 series entry in the printer database. the hpijs-standalone rpm threw me off - that’s completely useless in this case and only the full hplip-* rpm packages should be installed.

On August 16 I spelled out how I installed my HP C6280 under CUPS. I later did some web searching to see how to get the scanner to work. I did that by using the HP Device Manager Program.

Menu> search “HP”, selected HP Device Manager. From Device menu I selected “Setup new device”, from connection type I selected “Network/…” No Devices Found OK. Select “Find Manually”. I typed in, the address I had discovered mentioned in my Aug 16 post. My Photosmart showed up in the box, click “next”, selected c6100 driver option, and selected Finish.

I returned to CUPS and removed the printer setup that I had done on Aug 16.

I restarted the computer, and the HP Device Manager appeared in my panel in the lower right. Right click and select HP Device Manager… Opens the window, select Scan, and KDE Scanning is opened. The lower left box shows the c6200 series scanner selected. It works very well.

The HP Device Manager also gives status on ink, etc.

This setup has been much more convenient than the CUPS setup for me.

I followed your guide to install my new HP C6280 and it is perfect so thanks for it. Just one problem.
When i go on HP Device Manager and select scanner Kooka opens but doesn’t work :frowning: It seems it doesn’t recognize the scanner.
I installed xsane and it works but I’d like to use Kooka. Can you please help me to find solution?
Tks in advance
best regards

the sane project supports scanning in linux;

they have a list of compatible equipment; for HP

SANE: Supported Devices

you say xsane works; that suggests what is termed the back-end works;

the sane documentation suggests a couple of enquiries of your system:

SANE - Documentation


they suggest running the command


and if no joy, try as substitute user (su) or root as it is called

Thanks for your answer just what i don’t understand is that this means i cannot use kooka program (and sorry this is may be because I’m italian and not so good with english :slight_smile: )

Tks very much

I would suggest to you that if xsane works for you;

you do that;

that kooka would not be much better;

so why not just work with xsane for a while;

je peux parler francais, mais, malheureusement, je peux pas parler italien

Je comprendre toi bien :slight_smile:
you are right so I will go to use xsane for sure
Thanks very much for your cooperation
Best regards
A bientot