HP Pavillion ze4610 Keyboard Stops Working

I’m new to Linux. My machine is an HP Pavillion, ze4610us (1GB RAM; Athlon XP2500; Radeon 16P 320M; synaptics keyboard and trackpad)

I installed openSUSE 11.1/KDE 4.1.3 from the net, using Unetbootin. After the install, the keyboard and trackpad did not work. I installed a USB mouse and got the pointer to work, but still no key board response.

After some research, I found a reference to a similar problem that was “fixed” by booting with an external monitor attached. I did that and–joy of joys–it worked. After booting into failsafe mode, the keyboard and trackpad worked fine. I was able to repeatedly shutdown and reboot (even into normal mode) without the mouse or monitor attached.

Except that the problem returns. It seems to return after I doing anything involving admin privileges (in console or Yast). Usually it occurs after a shutdown and reboot. “Fixing” it requires rebooting into failsafe mode with an external monitor connected.

Can anyone advise me as to how to configure this properly? I don’t need to know what the monitor has to do with it, but I am interested!

Thanks in advance.