HP Pavillion DV6 AMD CPU Heat issue

This system runs three times hotter in linux than windows, doing the same tasks. I also have access to a DV4 with an almost identical spec/cpu and it runs much cooler.

Steps I have tried fix this issue.

  1. Using power management setting all the way down to aggressive power saving.

Nothing seems to make the system run cool enough to site on a table, never mind my lap. I am looking for things to try, so please don’t hold back. (I use a chile mate or a metal surface at all times )

OS Spec:

  • Opensuse 11.3
  • 32 Bit
  • KDE 4.4.4
  • Using Kwallet
    System Spec
  • HP DV6
  • AMD Chipset AMD Turion™ II Dual-Core Mobile M500

It sounds as if the cpu(s) are running at 100% all the time. Do you see cpu scaling (i.e., frequency changing from, say, 2700 MHz to 1200 MHz to 800 MHz) in “my computer”?

Turns out that it wasn’t the cpu that was over heating it was the gpu.

I would warn anyone running amd chipset on a DV6 from 2009 to be careful, the GPU tends to fail, the interesting part is that the failure is a well know issue in this model and yet hp didn’t issue a recall.

The GPU gets hot enough to unsolder itself causing it to fail, according to repair specialist I had look at it. It can be repaired but the cost is nearly equal to purchasing a new unit.

I’m also facing same problem. In my case this is happening only with openSuse 11.4. I also have Kubuntu 10.10 and win7, in both it does not heat up that much.

That is interesting, and as much as I love opensuse I wouldn’t advice using it with a laptop that has this issue.

I am wonder did you notice a difference while running flash?

Hmm, HP laptops had a lot of heating issues in Brazil when weld changed to lead-free. M/B contacts would fail with time and use. I have an old pavilion with onboard nvidia geforce 6500, but no (overheating) problems yet.

The graphical NVIDIA X Server Settings (nvidia-settings in the command line) show the GPU temperature, on some cards you can set clocking to make it run cooler (and slower).

I have a dv9000z from 3+ years ago, with the AMD Turion64 and the NVIDIA GeForce 6150,
and I’m noticing that the fan is running almost continously with openSUSE 11.4. It didn’t
with openSUSE 11.3 (from which I painfully “upgraded” a few days ago; zypper dup was a
debacle, and ended up doing a fresh install from the 11.4 DVD).

I am NOT seeing these heat problems on Fedora 14, Mandriva 2010.2 or Ubuntu Meerkat.
I do have a scratch 11.4 installation on a partition on the USB drive (that has F14, M2010.2,
and Meerkat as well), and will try some tests to see what’s different. There is also a thread
in the openSUSE mailing list, and one respondent mentioned Bug 653540, but I haven’t
researched that yet.

And, yes, this particular laptop of mine has been back to HP a couple of times for repairs,
once on their dime, and once on mine… Not fun…

Yes, I think mine is the same (6150, not 6500, I was quoting from memory).

TBH I think this will be solved the same as it was in 11.1/11.2/11.3, i.e., in time. Both new versions I installed (11.0 IINM and 11.2) had this issue at first. After a few weeks one of the updates - possibly a kernel one - solved the issue.

On a side note, about two or three months ago the space bar and keys in a vertical line from up/down arrows to backspace stopped working. I remapped most keys with Xmodmap and since I already have a usb keypad and small usb keyboard I haven’t yet got to fix it or buy another laptop - I rarely use it.

Same issue as the DV6, so I installed the ATI driver and then I turn on powerplay option. Once that was on I adjusted the gpu to it’s lowest performance level.

This has cooled the system 10 degree’s from 155/160 to 133/140, however this has broken sleep and hibernation completely.

The Open source driver seems to let the system get hotter and hotter. If there is a way to fix either issue I am all ears.

Also it seems kind of strange that opensuse is the only linux users in this thread have had issue with. I am wondering why that is, and why it hasn’t been fixed.