Hp Pavilion 17 with openSuse 13.2 device eno1 failed: operation

I have an HP Pavilion 17 laptop that came with window 8.1, I installed openSuSe 13.2. I cannot get the wireless to work.
I have run various checks and get the following using systemctl status network:

wicked service - wicked managed network interfaces
Loaded: loaded (usr/lib/systemd/system/wicked service; enabled)
Active: active(exited) since SUN 2015-08-02 08:11:58 PDT; 5min
Process: 863 ExecStart = /usr/sbin/wicked --systemd ifup all (code=exited, status=0/success)
mAINpid: 863 (CODE=EXITED, STATUS=0/success)
CGroup: /system.slice/wicked.service
Aug 02 08:11:58 host name wicked [863] : device eno1 failed: operation timed out
Aug 02 08:11:58 host name wicked [863] : lo up
Aug 02 08:11:58 host name wicked [863] : eno1 set-in-progress
Aug 02 08:11:58 host name wicked [863] : wlo1 up

I, also, checked for the firmware and it is in /lib/firmware.
ifconfig yielded a inet addr.

What do I try next?

Thanks for your help

Hello, to begin with:

Please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

When you say things like “ifconfig yielded a inet addr”, you better post this (between CODE tags) instead of telling stories

What the output you provide shows is that the cable itnterface (en01) is not working (maybe no cable plugged in) and that the wifi interface (wl01) is working.

Nevertheless you say “I cannot get the wireless to work.”, but your title indicates that the ethernet cable does not work.

Please tell more precise what you do, what you think that shlould happen and what happens instead. And yes, posting the output of

ip addr
ip route
grep -v '^#' /etc/resolv.conf

will give usefull information.

I ran the checks with both a cable plugged in and without. The results are as follows:

without cable connection
systemctl status network
#wicked.service - wicked managed network interfaces
Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled)
Active: active (exited) since Mon 2015-08-03 06:47:23 PDT; 6min ago
Process: 883 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
Main PID: 883 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/wicked.service

Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: device eno1 failed: operation timed out
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: lo up
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: eno1 setup-in-progress
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: wlo1 up #

with cable connection
#wicked.service - wicked managed network interfaces
Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled)
Active: active (exited) since Mon 2015-08-03 06:47:23 PDT; 15min ago
Process: 883 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
Main PID: 883 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/wicked.service

Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: device eno1 failed: operation timed out
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: lo up
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: eno1 setup-in-progress
Aug 03 06:47:23 SpeedRacerMobile2 wicked[883]: wlo1 up #

ip addr without cable connection

#1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 8c:dc:d4:71:36:87 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether ec:0e:c4:57:75:45 brd ff:ff:ff:ff:ff:ff
inet6 fe80::ee0e:c4ff:fe57:7545/64 scope link
valid_lft forever preferred_lft forever #

ip addr with cable connection

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever

2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 8c:dc:d4:71:36:87 brd ff:ff:ff:ff:ff:ff
inet6 fe80::8edc:d4ff:fe71:3687/64 scope link
valid_lft forever preferred_lft forever
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether ec:0e:c4:57:75:45 brd ff:ff:ff:ff:ff:ff
inet6 fe80::ee0e:c4ff:fe57:7545/64 scope link
valid_lft forever preferred_lft forever #

ip route was blank in both cases

grep -v ‘^#’ /etc/resolv.conf was also blank with and without cable

Hope this helps

Thanks

On 2015-08-03 23:56, reguspatoff wrote:
> I ran the checks with both a cable plugged in and without. The results
> are as follows:
>
> without cable connection
>
>
> systemctl status network
> #wicked.service - wicked managed network interfaces
> Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled)

Please, please, inside a code tags section, as requested. It is the #]
button in the forum editor.

> ip route was blank in both cases
>
> grep -v ‘^#’ /etc/resolv.conf was also blank with and without cable

Just post this way, no stories:


minas-tirith:~ # grep -v '^#' /etc/resolv.conf
minas-tirith:~ #

That tells us more :slight_smile:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

To begin with (and I repeat!):

Please use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

And as Carlos said, please post what is asked for in the way above. Then we will see for ourselves if there is output or not.

And I asjked you:

… you say “I cannot get the wireless to work.”, but your title indicates that the ethernet cable does not work.

Please tell more precise what you do, what you think that shlould happen and what happens instead. And yes, posting the output of

I do not see any explanation :(.

So please tell us how you did configure your network:

  • using Networkmanager or wicked?
  • using DHCP or not?
  • when not using DHCP, what parameters did you fill in where?

It will be very difficult to help you if you do not answer our questions, or at least explain why you do not want or are not able to answer them.

First Gentlemen, I do not have any button that has # on it. I have alot of smiley faces I am trying to answer your questions as well as I can.

The following is what I get when I type in your requested code.

SpeedRacerMobile2:/# ip addr

lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 8c:dc:d4:71:36:87 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether ec:0e:c4:57:75:45 brd ff:ff:ff:ff:ff:ff
inet6 fe80::ee0e:c4ff:fe57:7545/64 scope link
valid_lft forever preferred_lft forever

SpeedRacerMobile2:/# ip route
SpeedRacerMobile2:/#

SpeedRacerMobile2:/# grep -v ‘^#’ /etc/resolv.conf
SpeedRacerMobile2:/#

The output is the same whether the ethernet cable is plugged in or not.

I hope this is what you want

On 2015-08-04 18:36, reguspatoff wrote:
>
> First Gentlemen, I do not have any button that has # on it. I have alot
> of smiley faces I am trying to answer your questions as well as I can.

Then try again.

http://susepaste.org/images/15093674.jpg


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Apart from you not seeing the button with the # in it (I hope Carlos’ picture makes that clear to you), I had some questions, you apperently forgot to read, or you read them, but then you forgot to answer them.

Thank you for your help. The problem is solved; it was a DHCP configuration problem

Congratulations and thanks for reporting back.