Hp Parallel Port Printer on 11.4?

I’m using lxde as the desktop on 11.4. This old printer, Hp Deskjet 722C doesn’t seem to fit the mold!

The problem seems to be that yast > hardware > printer is expecting a printer in the gutenprint list. 7xx series Hp printers aren’t in that list, so the dialog is empty.

There doesn’t seem to be a way to point the yast > hardware > printer dialog to anything other than the gutenprint list. Am I correct about that?

I found a previous post using 11.2 that said to download a filter rpm. The 11.2 link given had expired, but changing 11.2 in the url to 11.4 was good and I installed that filter. That filter hasn’t been noticed by anything yet.

Someone on google went to sourceforge and got pnm2ppa. I got that tarball, built and installed it. That all seemed to complete well. pnm2ppa is in my path.

Some people on google have talked about manual printer configuration. Apparently the Hplip stuff is not compatible with paraport printers. I have Hplip installed, but it doesn’t understand the 722C.

The docs in the pnm2ppa tarball include scripts to print ps files and text files. The pnm2ppa docs also mention some cupsomatic utilities from cups.

Can I use the 11.4 printer tools to setup this printer, or is this printer one that has to be hand fed? Heboland.

Unlike many other HP models, this range if Deskjets do not seem to be supported by HP, and there is no gutenprint driver either. However, a quick search revealed that the pnm2ppa ghostscript filter may be ok to use:


One other ‘gotcha’ is that the parallel port ‘lp’ driver is not loaded at boot by default, so you may want to load it manually before attempting to configure your printer

modprobe lp

Download the ppd, then configure your printer via the CUPS web interface


Select ‘Add Printer’, enter your root credentials, and follow the prompts given. When you get to the model selection, navigate to the ppd file you downloaded.

Try a test print when finished.

I hope that works. :slight_smile:

Thank you Deano! You gave me very good instructions.

Prior to following your instructions, I didn’t know what the OpenPrinting was about, nor did I know anything about http://localhost:631/admin.

I’m assuming http://localhost:631/admin is something similar to a router URL setup page. http://localhost:631/admin works slick.

Whether the pnm2ppa tarball from sourceforge that I previously built and installed is in use, I’m not sure. Perhaps the PPD file let CUPS build it’s own pnm2ppa.

On thing remains that I would like to automate. What would you recommend for loading the lp module during boot? I have a dial-up system that boots each time I use it.

In the past I have added kernel options to grub. Also I have edited kernel settings, possibly using yast > system > sysconfig. I can’t remember exactly where I edited the kernel settings to load a module.

My 11.4 system has a /etc/modprobe.d directory, but not a modprobe.conf. The files in the modprobe.d aren’t complete enough to provide a template. The modprobe.d files seem to be modprobe options rather than commands.

In the modprobe.d files, there are references to /lib/modules, but this path is where I expect modules like lp to live.

I’m anxious to learn your preference for systematically loading lp. Heboland.

Hi Heboland. I’m glad that those instructions using the ghostscript filter worked for you.

Yes, CUPS has its own web config tool running within your system. It is a great feature IMHO, especially when configuring systems across a network.

I’m anxious to learn your preference for systematically loading lp. Heboland.

That is easy :slight_smile:

YaST >> System >> /etc/sysconfig Editor, navigate to System >> Kernel >> MODULES_LOADED_ON_BOOT, add ‘lp’ there, then OK.

When you next boot, this module should be loaded, ready to provide connectivity to your printer.

Hi Deano, You gave me great instructions again!

When I got to yast > system > sysconfig > system > kernel, I recognized the menu from past use. After adding lp to the previously empty line, lp now loads on bootup.

Thanks again for your help with this! Heboland.

No problem. Go well Heboland!

Deano, it’s OK to mark this thread solved if it hasn’t happened yet. I’ll leave that up to you.


Deano, it’s OK to mark this thread solved if it hasn’t happened yet. I’ll leave that up to you.

It’s not necessary. anyone searching here will see it has been anyway. :slight_smile: