hp Officejet Pro 8720 scanner no longer functional

Hello everyone,

a few days ago, after an update of Tumbleweed, all of a sudden the scanner of my hp Officejet Pro 8720 multifunction device was no longer functional. Xsane says “no devices available”. I tried to reconfigure the scanner in Yast/Scanner, but the 8720 didn’t appear in the list of supported devices any more. Printing on the same device is no problem.

scanimage -L resulted in:
[15:01:49.865359] [sanei_debug] Setting debug level of dll to 128.
[15:01:49.865561] [dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.1.1
[15:01:49.865590] [dll] sane_init/read_dlld: attempting to open directory ./dll.d' [15:01:49.865638] [dll] sane_init/read_dlld: attempting to open directory /etc/sane.d/dll.d’
[15:01:49.865682] [dll] sane_init/read_dlld: using config directory /etc/sane.d/dll.d' [15:01:49.865728] [dll] sane_init/read_dlld: considering /etc/sane.d/dll.d/hpaio [15:01:49.865776] [dll] sane_init/read_config: reading dll.d/hpaio [15:01:49.865822] [dll] add_backend: adding backend hpaio’
[15:01:49.865862] [dll] sane_init/read_dlld: considering /etc/sane.d/dll.d/epkowa.conf
[15:01:49.865905] [dll] sane_init/read_config: reading dll.d/epkowa.conf
[15:01:49.865936] [dll] add_backend: adding backend epkowa' [15:01:49.865974] [dll] sane_init/read_dlld: done. [15:01:49.866011] [dll] sane_init/read_config: reading dll.conf [15:01:49.866109] [dll] sane_get_devices [15:01:49.866137] [dll] load: searching backend epkowa’ in /usr/lib64/sane' [15:01:49.866164] [dll] load: trying to load /usr/lib64/sane/libsane-epkowa.so.1’
[15:01:49.866202] [dll] load: dlopen()ing /usr/lib64/sane/libsane-epkowa.so.1' [15:01:49.866816] [dll] init: initializing backend epkowa’
[15:01:49.970201] [dll] init: backend epkowa' is version 1.0.213 [15:01:49.971402] [dll] load: searching backend hpaio’ in /usr/lib64/sane' [15:01:49.971435] [dll] load: trying to load /usr/lib64/sane/libsane-hpaio.so.1’
[15:01:49.971471] [dll] load: dlopen()ing `/usr/lib64/sane/libsane-hpaio.so.1’
[15:01:49.990455] [dll] load: dlopen() failed (/usr/lib64/sane/libsane-hpaio.so.1: undefined symbol: _DBG)
[15:01:49.990505] [dll] sane_get_devices: found 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[15:01:49.990570] [dll] sane_exit: exiting
[15:01:49.990592] [dll] sane_exit: calling backend `epkowa’s exit function
[15:01:49.990738] [dll] sane_exit: finished

This showed clearly that there was something wrong with /usr/lib64/sane/libsane-hpaio.so.1, which is actually a link to /usr/lib64/sane/libsane-hpaio.so.1.0.0.
A little bit more investigation showed that in Leap 15.3 the scanner still worked. Copying the functional libsane-hpaio.so.1.0.0 from the Leap system to Tumbleweed fixed the problem.
So there must have been introduced an issue with the latest version of hplip-sane of 9th May 2022.

Could someone please explain to me how this bug should be officially reported? I could of course contact the developer being mentioned in the change log, but I don’t think that is the preferred way.

Regards,
Armin

hplip is broken, try hplip from printing:
https://bugzilla.suse.com/show_bug.cgi?id=1198794

I have exactly the same problem here, with my HP Color Laserjet Pro MFP M277dw.
Prints without problem, but scanner is dead. I have it connected through the network, not directly. Don’t know if it makes any difference.
The printer does not appear anymore in the list of supported printers, though the HPLIP site reports it as supported… which is obvious, as I have used it for years.

Cris

With the latest updates, the issue seems to be fixed.
Thanks for your replies.