HP Officejet 5740 can't configure

I just don’t understand how difficult simple print has become. My friend has an adsl modem/wifi router supplying her internet and her daughter can access the hp officejet 5740 AIO over the wifi on a windows 7 based pc. Using Linux leap 15.0 on my friends machine yields no results that work.

To clarify, under wifi connections the modem and the printer shows in the list of available items. I think she should have the modem chosen so she has internet and printing.

CUPS web service seems to be replaced by YAST->hardware->printers. If we select ipp:// it comes back with hp officejet 5740 and two options configure (which comes back no configurable printer available), and print test page (which sucessfully prints the test)

Back on the main printers list after closing the add printer box it says unknown printer, unknown driver, set as default.

Trying to print from an app simply gives print to file.

Next we connected the printer via usb which gave us the option of using hp-set-up which does step 1 -> step 2 -> step 3 and when you click finish as it sucessfully found the printer and supposedly set it up it brings you back to step 1 again and clears the list of found printers.

Then tried using hplip which can’t find any printers connected or wifi, hplip-cups which can find hp-officejet 5740 usb but no suitable drivers available.

The printer worked fine and was easy to set-up using cups web interface on opensuse 13.2, and 42.1 but does not function at all with 42.2, 42.3 or 15.0 . It must be that I have lost my marbles because a more advanced linux should still be able to print. What am I doing wrong.

Use hp-setup to configure, but ensure the cups service is enabled and running first, then as your user run hp-toolbox and all should be good.

systemctl status cups
systemctl start cups
systemctl enable cups

ok will try that when she cools off. I take it you run systemctl as root and hp-setup likewise then run hp-toolbox as normal user.
I have a cannon and an epson so the hp stuff I can’t check on my end.

BIG … THANKS for setting back on path to sanity

Still up to my ass in aligators. 6 hours worth.

In terminal as super user used the 3 systemctl commands and confirmed cups is ok
Then did the hp-setup
screen 1 chose the wireless/802.11 -> Next (1 of 3)
screen 2 plug - in USB and click refresh, shows hp-officejet 5740 in list -> Next (2 of 5)
screen 3 Network modem discovered -> WPA -> password entered -> disconnect USB -> Connect (3 of 5)
screen 4 Click Finish - You have successfully set up your printer and it is ready -> Finish (4 of 5)

  • test page prints perfect in screen 4
    screen 1 Device Discovery choose connection method : 0 defined devices found (1 of 3)

Used Yast - > hardware -> printers to remove all printers and tried the above again with same results
Used Yast -> hardware -> printers and no printers defined -> chose add using hp-setup same sequence repeats with same results only this time unknown printer appears on the list no driver and as default

Tried to print to unknown printer says not a PDF file no PPD file

I finally had her boot to old opensuse live kde 13.2 on usb flashdrive
did manage Printers -> cups web interface => add Printer => wifi -> ->hp officejet 5740 series detected
prints test page perfect, tried document and prints perfect

I always have my canon all-in-one plugged into usb port but it too is wireless capable so tried to set it up wireless and it too works using the 13.2 flashdrive and cups but can’t be found by Yast in leap 15.0 unless I plug in the USB and choose USB local printer.

I’m stumped and my friend is so upset I expect her to throw the computer out the window.

BTW hp-toolbox says not compatible with hplip-cups automatic updates are off due to security risk report to bugzilla

Should ignore the online updates and stick with the distribution version…

I’ve never used YaST for HP printers only hp-setup, just make sure cups is running, for my printer it downloaded the plugin.

Does the printer have a web interface? I have mine set to a static ip address (It’s a P1102w).

Yast -> hp-setup and super terminal -> hp-setup both function identical. At step 4 when you click finish it is supposed to put up summary screen with exit/close button but it loops back to step 1 clearing all previous defined printers.

Her printer has web interface. Communicates wirelessly with modem/router which also connects wirelessly to daughters pc at other end of house. Using flashdrive kde-live 13.2 it talks wirelessly with Linux pc my friend is using. But Leap 15.0 kde-live flashdrive and Leap 15.0 on hdd and gecco linux 42.3 on flashdrive can’t seem to find and keep the printer. She can use ipp:// in Yast but that produces unknown printer - no device driver. Using that printer to try and print flashes the light on the printer but does not print.

I have installed my HP-Envy first completly as USB printer with hp-setup, after that I have installed the Printer as network printer with hp-setup.

Thats also the way described in the documentation for installing this printer in windows…

Need to figure out what is wrong:
opensuse 13.2 usb-live works usb or wifi no issues installed using CUPS web interface
opensuse 42.1 usb-live works usb or wifi no issues installed using CUPS web interface

  • No more cups web interface now done by YAST & / or hp-setup
    opensuse 42.2 , opensuse 42.3 works usb but no wifi
    gecko-Linux 42.3 based live occassionally works usb but does not keep settings between powerdowns
    opensuse 15.0 , opensuse 15.0 live occassional works usb,
    …finds printer in hp-setup as a wifi and prints test page says everything is good but when you click finish starts over

Last night when we shut down we had no printer capability today she called after booting her system and printer is totally fine.
She can print wirelessly. Don’t understand how that is possible since last night it had not keep the printer defined through hp-setup
but guess we will never know what a reboot did that fixed things.

Thanks everyone.