HP Lips Printer Driver stops often, restarts only via root user

Could someone help me finding a work around to the following problem?:frowning:

I installed the HPLips printer driver for my HP Officejet Pro 8500 Printer.

The driver often stops printing on its own (HP Device Manager => “Printer Control” tab shows “stopped”). I guess it does so when it encounters a situation where it cannot print right on.

The problem: Users without root permission cannot restart printing, even when everything is o.k… They have to call me in order to “start printer”, because restarting it needs root access.

Does anyone know how to solve the problem: either setting the driver not to turn to “stopped” or permitting a restart by normal users? :slight_smile:

Try having a look at the cups settings. hplip is great, but you need to set the defaults in cups.
Open a browser and go to localhost:632 to open the cups servers web interface and set up the defaults from there.
Depending on whether you have a linux or windows network:
In linux, set hplip on one master pc and share it from there via cups. You can then use a single point to admister the printer.

Else …

If you want to use hplip on every pc in the network, you need to set up cups on each pc to allow the local users rights to control the printer.

On my hp jetdirect network printers, the only time there is a problem is when a manual user intervention at the printer is required (like feed letter when the printer defaults are A4) so hplip works fine without any extra setup.

Hope this helps.

BTW, you should probably have posted this in the hardware or applications section since it’s not an OS install/boot/login question.

You should add your users to the ‘lp’ group via Yast:

Yast > Security and Users > User and Group Management

Hello

:wink: Thanks a lot for your answering. :frowning: Yet the problem is not solved:

  • I added the user to the group lp, logged out an logged in again. “HP Device Manager” still requested root access, to “stop” / “restart printer”.

  • Using the web interface cup-setup, does not help either, because I would have to disclose the root password to the user, for him to “start printer” after it stopped on its own.

:\ - Clarifying my situation: I installed HPLips on each of my computers, because they have to be able to print directly via network (there is no server allways available, the printer acts as a server on its own).

  • Maybe someone can tell me, what I have to do, to grant root control to the cup server, without disclosing my root password. In my case, this would probably solve the problem.

Thanks a lot

Dieter

If you do a bit of reading for cups, you can set which users are allowed admin rights to printers (It’s in one of the config files and don’t remember which one off hand).

Thanks folks: found the answer with your help.

rotfl! This is what I did:

  • Added users to group lp
  • Added group lp to the SysGroup line in the cupsd.conf file

This way I granted access to the cup configuration, and can stop / start the printer even from the HL Device Manager

In addition to this, I found a setting in the Yast Printer Configuration Module, which permits me to change behavior of the driver in case of a failure to print. Up to now it was set to stop the printer (default configuration). I set it to try again printing without stopping the printer.

:wink: Comments:

  • I suggest Suse changes the default settings for the cup driver, to include the lp group in the SysGroup line of the cupsd.conf file, and to set the printer retrying on failure. For beginners the present default setting are quite cumbersome.

Thanks again

Dieter

Issue is solved

You think everyone has an HP printer and uses that software?