HP LaserJet P1505

Hi. I try find anything on this forum to solve my problem, but nothing search. May be u can help me? Every time when I switch on printer appear a window of gnome-cups-add where for me to make a proposal install new printer. How I can get rid of them?

I have same printer , and works perfect.All you have to do is to add printer in hplip,not in yast.If you added in yast , first remove it.
Hope this will help

Im sory - it doesnt help.The window appear again & again.
I remove my printer from yast and added it on hplip-tool with a terminal: su - -c “hp-setup”. But when I switch on printer, appear gnome-cups-add >:(
It`s real exasperate

I don’t remember typing anything…
Can’t you do this from more applications > system >hptoolbox ? It will ask you for user (root) and pass , nothing more.
Did you tried “make cups” as root after adding?
cups is here http://localhost:631 Your printer should be in "printers " tab,if no go “administration” and add it.Use web browser ,naturally.
Just one thing, when hptool ask you “do you want to download …”(or something similar) say “yes”.
I have no ideas left, so …good luck

Hey, man thankx for answers, but I solved problem this way: I install foo2xqx driver from here

[foo2xqx: a linux printer driver for XQX stream protocol](http://foo2xqx.rkkda.com)

It`s real work great.:wink:

Yes I know about that driver, i also installed (at first somehow hptool did not work,or I did not know how), but hptool works better.
Try to print a table from OO calc,vertical borders not printing (my case) with foo2xqx driver .I tried with different resolutions.
With hptool everything works great!

I think my problem was I forgot add my user in lp group… Do you know where I can read more about groups in Linux?