hp installation problem

Hi all!
I have hp pavilion dv6 1386et notebook with windows 7 home premium package. I tried to install suse. But there is something wrong.First I have tried to istall suse 10.3 but installation screen did not appear.Then I tried it with suse 11.2, it was hopeful than 10.3. Installation screen opened and after first rebooting screen have got frozen.So I reboot it manual.Installation only continued with failsave. It has finished, I heard sound of opening system but screen was black.
Can anyone help me?

Does this machine have an ATI video chip??

It looks like it has an ATI Radeon HD 4650 :frowning:

Boot to the command line by pressing 3 at the boot menu.

log in as root


sax2 -r -m 0=vesa (note: zero not capital o)

init 5
this should start the GUI

yes it has ATI Radeon HD 4650.

gogalthorp, I will try your advices tonight.

hi again.
what do you think cause this problem?
graphic card, suse or hp?

There are major problems with ATI cards with 11.2. There are lots of threads here devoted to the problem.

Hi slmrcn, here is some basic information on openSUSE graphic drivers, to help you understand any recommendations that you may get from this thread: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

slmrcn if it was me with the problem, I would boot to run level 3 (the link I provided above describes how) and then try removing any /etc/X11/xorg.conf file (if there is any) and reboot. Chances are there is no such file.

If there is no such file, then I would try the radeonhd driver and reboot. If that did not work I would try the radeon driver and reboot. If that did not work I would try the vesa driver.

If I did not like what I got from the radeon driver and/or the radeonhd driver, I would update my graphic driver to a cutting edge version, cross my fingers, and try that.

More specifically, if you are willing to take a chance, you could try the latest very cutting edge open source drivers unofficially packaged for openSUSE for ATI hardware. ie … some openSUSE-11.2 users with “legacy” ATI hardware have found they get better behaviour on openSUSE-11.2 from the open source radeon and radeonhd drivers if they use the updates from the X11 : XOrg repository. That repository is here:


… and the rpms that some of us found gave better behaviour are these apps:

  • mesa
  • xorg-x11-driver-input
  • xorg-x11-driver-video
  • xorg-x11-driver-video-radeonhd
    and possibly ( ? ) others for a 64-bit openSUSE ? … (I tried them on a 32-bit PC). One caution - that tends to be a cutting edge repository, so there is always a risk it will make things worse when a cutting edge release has a bug.

Also, note, because that repository is so cutting edge, I recommend it be added, the rpms installed, and the repository removed. Do NOT leave that repository enabled 1 update longer than necessary.

If you need any guidance on how to add respositories or install rpms via yast please advise.

Note I will be going away for 2 weeks in around 24-hours, so others may need to pick up the ball and help you if you have difficulties.

I have installed catalyst it did not solve problem.and also I have applied your advices. The default session of suse 11.2 does not open, I logged two or three times with failsafe session but I could not achieved any succes.What do you recommend me to do now?