HP DV6 11.3 Crash after Catalyst install

I added the Repo for ATI and continued on to install a few other pieces of software. I missed the driver and kernel module slipping into the install job.

To make a long story some what shorter I now have an expensive brick if I want to run in anything but safe mode.

I have followed several howto’s, nothing has worked, all I want to do is remove the ATI driver and activate the open source radeon driver.

Uninstalling and removing the ATI Catalyst driver had failed to do this however.

System Spec:
DV6 2043
CPU: AMD X2 M500
Ram: 4GB
Video: 128MB Dedicated Radeon HD4200

Does any one know a way to restore the Open source driver to full uses?

Depends on how you installed the proprietary driver.

What is the output of:

rpm -qa '*fglrx*'

Here is the output of the command


fglrx_7_5_0SUSE113-9.&53-1.i386

I have tried both methods, which means I have complicated the removal process. I just want to get the system up and running, so is there a sure fired way to basically start fresh other than reinstalling?

Remove this rpm.

ie

rpm -e fglrx_7_5_0SUSE113-9.&53-1.i386

Error after removal:

xauth: creating new authority file /root/.serverauth.24015

X.Org X Server 1.8.0
Release Date: 2010-04-02
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-50fa 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 i686
Kernel command line: root=/dev/disk/by-id/ata-Hitachi_HTS725032A9A364_091106PC6300VKG1Y2BA-part8 apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
Build Date: 19 August 2010 02:31:09PM

Current version of pixman: 0.18.2
Before reporting problems, check X.Org Wiki - Home
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Aug 23 20:14:01 2010
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(EE) Failed to load module “fglrx” (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at X.Org Wiki - Home
for help.
Please also check the log file at “/var/log/Xorg.0.log” for additional information.

giving up.
xinit: No such file or directory (errno 2): unable to connect to X server

Step one thanks to oldcpu.

rpm -e fglrx_7_5_0SUSE113-9.&53-1.i386

Step two removed these files so the system could recreate the xorg.conf.

rm /etc/X11/xorg.conf"

Second files location /etc/X11/xorg.conf.d/"

rm xorg.conf.fglrx-postun 

Thats what worked for me.


Steps that didn’t work by themselves

  • Using the ati uninstall.sh
  • Un-installing the driver using Software management
  • Also tried allot of other combinations with my linux mates, things involving depmod, modprobe, etc
  • keeping it simple worked this time, thanks again oldcpu

Posted that last on my mates system and it seems I used his logged in account.

J100 ??? Where did you come from ??

… similar problem ?

Please look at post#8 of megabooks!

Good luck.