HP DV5 1020er sound problem

After installing opensuse 11.1 sound is not working, following Alsa-update - openSUSE after installing new drivers trying to restart alsa I got message :
rcalsasound restart

# rcalsasound restart
Starting sound driver:  hda-intelWARNING: Error inserting snd (/lib/modules/2.6.27.7-9-default/updates/alsa/acore/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.27.7-9-default/updates/alsa/acore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.27.7-9-default/updates/alsa/acore/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.27.7-9-default/updates/alsa/acore/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)

and so on,
dmesg shows

snd_hwdep: Unknown symbol snd_lookup_oss_minor_data
snd_hwdep: Unknown symbol snd_lookup_minor_data
snd_hwdep: Unknown symbol snd_ctl_register_ioctl_compat
snd_hwdep: Unknown symbol snd_card_file_remove
snd_hwdep: Unknown symbol snd_register_device_for_dev
snd_hda_codec: Unknown symbol snd_verbose_printd
snd_hda_codec: Unknown symbol snd_hidden_kzalloc
snd_hda_codec: Unknown symbol snd_ctl_add
snd_hda_codec: Unknown symbol snd_card_proc_new
snd_hda_codec: Unknown symbol snd_add_device_sysfs_file
snd_hda_codec: Unknown symbol snd_hidden_kcalloc
snd_hda_codec: Unknown symbol snd_hidden_kfree
snd_hda_codec: Unknown symbol snd_ctl_remove
snd_hda_codec: Unknown symbol snd_ctl_find_id
snd_hda_codec: Unknown symbol snd_verbose_printk
snd_hda_codec: Unknown symbol snd_ctl_new1
snd_hda_codec: Unknown symbol snd_component_add
snd_hda_codec: Unknown symbol snd_ctl_make_virtual_master
snd_hda_codec: Unknown symbol snd_iprintf
snd_hda_codec: Unknown symbol snd_ctl_boolean_mono_info
snd_hda_codec: Unknown symbol snd_hwdep_new
snd_hda_codec: Unknown symbol snd_hidden_kstrdup
snd_hda_codec: Unknown symbol snd_device_new
snd_hda_codec: Unknown symbol _snd_ctl_add_slave
snd_hda_codec: Unknown symbol snd_pci_quirk_lookup
snd_hda_codec: Unknown symbol snd_hidden_kmalloc
snd_hda_codec: Unknown symbol snd_device_free
snd_hda_codec: Unknown symbol snd_pcm_hw_constraint_step
snd_hda_codec: Unknown symbol snd_hidden_kstrndup
snd_hda_codec: Unknown symbol snd_pcm_format_width
snd_hda_intel: Unknown symbol snd_verbose_printd
snd_hda_intel: Unknown symbol snd_hidden_kzalloc
snd_hda_intel: Unknown symbol snd_pcm_new
snd_hda_intel: Unknown symbol snd_pcm_limit_hw_rates
snd_hda_intel: Unknown symbol snd_card_register
snd_hda_intel: Unknown symbol snd_card_free
snd_hda_intel: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_hda_intel: Unknown symbol snd_hda_bus_new
snd_hda_intel: Unknown symbol snd_hidden_kcalloc
snd_hda_intel: Unknown symbol snd_hidden_kfree
snd_hda_intel: Unknown symbol snd_hda_build_pcms
snd_hda_intel: Unknown symbol snd_pcm_set_sync
snd_hda_intel: Unknown symbol snd_verbose_printk
snd_hda_intel: Unknown symbol snd_hda_codec_new
snd_hda_intel: Unknown symbol snd_hda_queue_unsol_event
snd_hda_intel: Unknown symbol snd_hda_power_up
snd_hda_intel: Unknown symbol snd_pcm_sgbuf_get_chunk_size
snd_hda_intel: Unknown symbol snd_pcm_lib_malloc_pages
snd_hda_intel: Unknown symbol snd_pcm_lib_ioctl
snd_hda_intel: Unknown symbol snd_pcm_lib_free_pages
snd_hda_intel: Unknown symbol snd_hda_power_down
snd_hda_intel: Unknown symbol snd_hda_calc_stream_format
snd_hda_intel: Unknown symbol snd_pcm_set_ops
snd_hda_intel: Unknown symbol snd_hda_suspend
snd_hda_intel: Unknown symbol snd_device_new
snd_hda_intel: Unknown symbol snd_pcm_sgbuf_ops_page
snd_hda_intel: Unknown symbol snd_pcm_suspend_all
snd_hda_intel: Unknown symbol snd_card_disconnect
snd_hda_intel: Unknown symbol snd_hda_resume
snd_hda_intel: Unknown symbol snd_pcm_hw_constraint_integer
snd_hda_intel: Unknown symbol snd_hda_build_controls
snd_hda_intel: Unknown symbol snd_pci_quirk_lookup
snd_hda_intel: Unknown symbol snd_card_create
snd_hda_intel: Unknown symbol snd_pcm_period_elapsed
snd_hda_intel: Unknown symbol snd_pcm_hw_constraint_step
snd: Unknown symbol unregister_sound_special
snd: Unknown symbol register_sound_special_device
snd: Unknown symbol sound_class
snd_timer: Unknown symbol snd_verbose_printd
snd_timer: Unknown symbol snd_hidden_kzalloc
snd_timer: Unknown symbol snd_info_register
snd_timer: Unknown symbol snd_info_create_module_entry
snd_timer: Unknown symbol snd_info_free_entry
snd_timer: Unknown symbol snd_hidden_kfree
snd_timer: Unknown symbol snd_verbose_printk
snd_timer: Unknown symbol snd_iprintf
snd_timer: Unknown symbol snd_ecards_limit
snd_timer: Unknown symbol snd_oss_info_register
snd_timer: Unknown symbol snd_unregister_device
snd_timer: Unknown symbol snd_hidden_kstrdup
snd_timer: Unknown symbol snd_device_new
snd_timer: Unknown symbol snd_hidden_kmalloc
snd_timer: Unknown symbol snd_register_device_for_dev
snd_pcm: Unknown symbol snd_verbose_printd
snd_pcm: Unknown symbol snd_hidden_kzalloc
snd_pcm: Unknown symbol snd_info_register
snd_pcm: Unknown symbol snd_info_create_module_entry
snd_pcm: Unknown symbol snd_ctl_unregister_ioctl_compat
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_info_free_entry
snd_pcm: Unknown symbol snd_add_device_sysfs_file
snd_pcm: Unknown symbol snd_info_get_str
snd_pcm: Unknown symbol snd_hidden_kcalloc
snd_pcm: Unknown symbol snd_hidden_kfree
snd_pcm: Unknown symbol snd_verbose_printk
snd_pcm: Unknown symbol snd_ctl_register_ioctl
snd_pcm: Unknown symbol snd_card_file_add
snd_pcm: Unknown symbol snd_iprintf
snd_pcm: Unknown symbol snd_major
snd_pcm: Unknown symbol snd_unregister_device
snd_pcm: Unknown symbol snd_timer_new
snd_pcm: Unknown symbol snd_device_new
snd_pcm: Unknown symbol snd_ctl_unregister_ioctl
snd_pcm: Unknown symbol snd_lookup_minor_data
snd_pcm: Unknown symbol snd_ctl_register_ioctl_compat
snd_pcm: Unknown symbol snd_info_create_card_entry
snd_pcm: Unknown symbol snd_power_wait
snd_pcm: Unknown symbol snd_hidden_kmalloc
snd_pcm: Unknown symbol snd_device_free
snd_pcm: Unknown symbol snd_card_file_remove
snd_pcm: Unknown symbol snd_register_device_for_dev
snd_pcm: Unknown symbol snd_device_register
snd_pcm: Unknown symbol snd_info_get_line
snd_hda_intel: Unknown symbol snd_pcm_period_elapsed
snd_hda_intel: Unknown symbol snd_pcm_hw_constraint_step
st: Version 20080504, fixed bufsize 32768, s/g segs 256

Any ideas how to fix this will be appreciated

You likely need to add “options snd-hda-intel model=hp-m4 enable_msi=1” as the first line to your /etc/modprobe.d/sound file. But you may have other problems as well. If you search our forum with a combined “dv5” and user “oldcpu” search, you will find many examples of my trying to help dv5 users with their sound (fortunately successful most of the time with basic sound).

Its also possible your PC has other problems affecting your PC’s sound. So please open a gnome terminal or kde konsole, type “su” (no quotes) to get root permissions (enter root password when prompted) and then type:
/usr/sbin/alsa-info.shyou may need to run it twice. Post here ONLY the URL that it provides. Just the URL.

Also post here the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q | libasound2
uname -a
cat /etc/modprobe.d/sound
with that I may be able to provide a specific recommendation, as opposed to a general suggestion.

http://www.alsa-project.org/db/?f=ad1915661f6636a60fa7883604a96740eda202a9 here is output of /usr/sbin/alsa-info.sh

and here is the rest:

rpm -qa | grep alsa
alsa-tools-1.0.19.git20090120-1.4
alsa-utils-1.0.19.git20090120-1.3
alsa-plugins-pulse-1.0.18-6.13
alsa-firmware-1.0.19.git20090120-1.1
alsa-plugins-1.0.18-6.13
alsa-driver-kmp-default-1.0.19.20090124_2.6.27.7_9.1-1.1
alsa-1.0.19.git20090122-1.1

rpm -qa | grep pulse
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-module-bluetooth-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
libpulse0-32bit-0.9.12-9.6
libpulse0-0.9.12-9.5
libpulse-browse0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
pulseaudio-module-gconf-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
libpulsecore4-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5

rpm -qa | libasound2
bash: libasound2: command not found

uname -a
Linux linux-9cdh 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

 cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
options snd-hdal-intel model=hp-m4 enable_msi=1
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

One more thing, I not sure whether I should start a new thread or not I noticed that ACPI is not working too. Fan is working always, sometimes it is too irritating.

acpi -V
     Battery 1: charged, 100%, rate information unavailable.
No support for device type: thermal
  AC Adapter 1: on-line

That should have read “rpm -q libasound2”. You need libasound2 for sound. Please confirm it is installed, and if it is not installed, then please install libasound2 from the same location from which you updated the other alsa commands (ie the versioning must be consistent).

Please change this file, and put the options line at the VERY START of the file. ie please change the /etc/modprobe.d/sound file to read:

options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

and restart your PC, and test your audio.

Note the line is:
options snd-hda-intel model=hp-m4 enable_msi=1

and not:
options snd-hda1-intel model=hp-m4 enable_msi=1

Please start a new thread. You are not likely to garner any attention from our ACPI experts with a title that states “HP DV5 1020er sound problem”. You need a new thread in an appropriate forum sub area.

When testing your sound, please copy and paste the following speaker test into a gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a lady’s voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

Note in your mixer you should move your PCM and master volume controls up to 95% when testing for basic sound functionality. Once you have basic sound, you should back off on those volume controls to a lower level to reduce distortion.

Thanks a lot for you help, however libasound2 seems to be present in system:

rpm -q libasound2
libasound2-1.0.19.git20090122-1.1

hm, seems to be ok if checking like this:


# rpm -qa libasound2
libasound2-1.0.19.git20090122-1.1
# rpm -qa | grep libasound2
libasound2-32bit-1.0.18-8.7
libasound2-1.0.19.git20090122-1.1
 speaker-test -c2 -l5 -twav

speaker-test 1.0.19

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 4,595751
 0 - Front Left
 1 - Front Right
Time per period = 4,561391
 0 - Front Left
 1 - Front Right
Time per period = 4,579939
 0 - Front Left

shows there should be sound, but I am not hearing anything, also in volume control I have:Playback: Null Output(Pulse Audio Mixer)

Please go to YaST > Hardware > Sound > Other > Volume and ensure both PCM and Master volume levels are set high. Also go into your mixer and ensure PCM and master volume are up to 95% or so for the test.

Then (again) run in a konsole or gnome terminal: cat /etc/modprobe.d/soundand post here what is there.

Also again post here the output of: /usr/sbin/alsa-info.sh so I can see your mixer settings.

Unfortunately there are no sound devices at all

Then (again) run in a konsole or gnome terminal: cat /etc/modprobe.d/soundand post here what is there.

cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.DVex+nmP8+5:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# NXNs.HS4OKn_IlZ0:RV620 Audio device [Radeon HD 34xx Series]
alias snd-card-1 snd-hda-intel

Also again post here the output of: /usr/sbin/alsa-info.sh so I can see your mixer settings.

http://www.alsa-project.org/db/?f=1664765a7c493e8f7d0b3c9ab467c3eecd23c995

This suggests to me you have a corrupted alsa rpm. Please re-install the alsa rpms per the URLs referenced in this guide (I think you have done this once already): Alsa-update - openSUSE

Then, after that update, reboot, and if no sound after a reboot, try running with root permissions “alsaconf” (with no quotes). After alsaconf is complete, go to /etc/modprobe.d/sound file, and add the line (at the start of the file): options snd-hda-intel model=hp-m4 enable_msi=1

Then restart your PC. Does that make a difference? Does your sound work then?

If your sound still does not work, restart your PC, and immediately after the restart run the following dmesg/curl command (with your PC connected to the internet) from a terminal / konsole and post here the output URL:
dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a