HP DM1z Realtek Card Reader ID 0bda:0138 Not Working

I have verified the device using lsusb which returns:

Bus 002 Device 004: ID 0bda:0138 Realtek Semiconductor Corp. Card reader

In Mint/Ubuntu it was as easy as following this post Installing Debian Linux on an Acer 5253-BZ602 laptop

But that doesn’t seem to work on SUSE so I’m not sure what to do.

The card reader is basically your standard internal sd card reader, and my setup is Hp Dm1z/OpenSUSE 12.1 x64/Gnome Shell 3.2. When I enter the card I get this in dmesg:

 6256.686297] usb 2-2: new high speed USB device number 6 using ehci_hcd
 6256.816421] usb 2-2: New USB device found, idVendor=0bda, idProduct=0138
 6256.816434] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
 6256.816443] usb 2-2: Product: USB2.0-CRW
 6256.816450] usb 2-2: Manufacturer: Generic
 6256.816456] usb 2-2: SerialNumber: 20090516388200000
 6256.839424] scsi5 : usb-storage 2-2:1.0
 6257.844375] scsi 5:0:0:0: Direct-Access     Generic- Multi-Card       1.00 PQ: 0 ANSI: 0 CCS
 6257.844992] sd 5:0:0:0: Attached scsi generic sg2 type 0

and when I disconnect it:

 6273.835362] sd 5:0:0:0: [sdc] Attached SCSI removable disk
 6300.567777] usb 2-2: USB disconnect, device number 6


Another learning curve: I figured out how nice it is to use bluetooth to transfer files instead of switching to another distro where the card reader works.


Perhaps I need to look over dmesg and logs further, I dd read that sometimes its seen as a scsi device?


i went over to realtek and the only drivers i see for linux are for a pcie reader not usb, I have the windows drivers so im thinking of trying them in a virtualbox setup with passthrough, I’m sure it’ll work that way but thats going pretty far. i cant find much on google about this card reader either, odd coming from an hp device lol…


Has anyone perhaps seen drivers for this somewhere. I happened to lose the windows drivers, and now I can’t even find them as I reinstalled windows. Realtek drivers don’t work at all, perhaps I will open a post on HP asking for at least the windows drivers as they are the only ones that had them and their link is broken.

What a useless no good card reader that only works in ubuntu lol. ( sure probably debian too but oh well )

Just some info: Trying the directions above results in the following:

rmmod usb_storage

ERROR: Module usb_storage does not exist in /proc/modules

so i go ahead and try to add it anyways

modprobe usb_storage
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.

nothing displays, so maybe it worked? moving on, i remove and insert the card just to be sure of the device before hand and ran dmesg:

663.794540] sd 3:0:0:0: [sdb] READ CAPACITY failed
663.794553] sd 3:0:0:0: [sdb] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
663.794559] sd 3:0:0:0: [sdb] Sense not available.
663.794707] sd 3:0:0:0: [sdb] Write Protect is off
663.794721] sd 3:0:0:0: [sdb] Mode Sense: 00 00 00 00
663.794822] sd 3:0:0:0: [sdb] Asking for cache data failed
663.794830] sd 3:0:0:0: [sdb] Assuming drive cache: write through
663.795441] sd 3:0:0:0: [sdb] Attached SCSI removable disk
674.203086] usb 2-2: new high speed USB device number 5 using ehci_hcd
674.331872] usb 2-2: New USB device found, idVendor=0bda, idProduct=0138
674.331887] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
674.331894] usb 2-2: Product: USB2.0-CRW
674.331898] usb 2-2: Manufacturer: Generic
674.331901] usb 2-2: SerialNumber: 20090516388200000
674.356748] scsi4 : usb-storage 2-2:1.0
675.360940] scsi 4:0:0:0: Direct-Access Generic- Multi-Card 1.00 PQ: 0 ANSI: 0 CCS
675.361427] sd 4:0:0:0: Attached scsi generic sg1 type 0
691.351809] sd 4:0:0:0: [sdb] Attached SCSI removable disk

so i try to mount it as sdb1

:/ # mount /dev/sdb1 /my-mount-point 
mount: special device /dev/sdb1 does not exist

so i try something else:

:/ # mount /dev/sg1 /my-mount-point 
mount: /dev/sg1 is not a block device

i also tried sg0 which is the same error. if i matter i checked /dev and don’t see any sdb listed:

:confused: # ls /dev
.sysconfig loop1 sda3 tty20 tty47 ttyS7
ati loop2 sda4 tty21 tty48 uinput
autofs loop3 sda5 tty22 tty49 urandom
block loop4 sda6 tty23 tty5 v4l
bootsplash loop5 sda7 tty24 tty50 vcs
bsg loop6 sda8 tty25 tty51 vcs1
btrfs-control loop7 sdb tty26 tty52 vcs10
bus mapper sg0 tty27 tty53 vcs2
char mcelog sg1 tty28 tty54 vcs3
console mem shm tty29 tty55 vcs4
core mqueue snapshot tty3 tty56 vcs5
cpu net snd tty30 tty57 vcs6
cpu_dma_latency network_latency stderr tty31 tty58 vcs7
disk network_throughput stdin tty32 tty59 vcsa
fb0 null stdout tty33 tty6 vcsa1
fd nvram tty tty34 tty60 vcsa10
freefall oldmem tty0 tty35 tty61 vcsa2
full port tty1 tty36 tty62 vcsa3
fuse ppp tty10 tty37 tty63 vcsa4
hidraw0 psaux tty11 tty38 tty7 vcsa5
hpet ptmx tty12 tty39 tty8 vcsa6
hugepages pts tty13 tty4 tty9 vcsa7
initctl random tty14 tty40 ttyS0 vga_arbiter
input rfkill tty15 tty41 ttyS1 video0
kmem rtc tty16 tty42 ttyS2 xconsole
kmsg rtc0 tty17 tty43 ttyS3 zero
log sda tty18 tty44 ttyS4
loop-control sda1 tty19 tty45 ttyS5
loop0 sda2 tty2 tty46 ttyS6

i also verified that this does still work under mint/ubuntu/deb/w.e, and that’s the only system i can use the card reader on right now.

i also found this post regarding usb cdroms, perhaps it can be of assistance, i dont know yet. so i decide i might as well run lsmod to see if a familiar module is loaded:

 # lsmod
Module                  Size  Used by
vfat                   17535  0 
fat                    65607  1 vfat
ip6t_LOG               17095  7 
xt_tcpudp              12924  18 
xt_pkttype             12504  5 
ipt_LOG                13040  7 
xt_limit               12711  14 
rfcomm                 77995  8 
bnep                   19817  2 
ip6t_REJECT            12974  3 
nf_conntrack_ipv6      14349  4 
nf_defrag_ipv6         18438  1 nf_conntrack_ipv6
ip6table_raw           12683  1 
xt_NOTRACK             12504  4 
ipt_REJECT             12576  3 
iptable_raw            12678  1 
iptable_filter         12810  1 
ip6table_mangle        12740  0 
nf_conntrack_netbios_ns    12665  0 
nf_conntrack_broadcast    12589  1 nf_conntrack_netbios_ns
cpufreq_conservative    13821  0 
nf_conntrack_ipv4      14783  4 
nf_defrag_ipv4         12729  1 nf_conntrack_ipv4
cpufreq_userspace      13162  0 
vmsync                 13068  0 
ip_tables              27717  2 iptable_raw,iptable_filter
cpufreq_powersave      12618  0 
xt_conntrack           12760  8 
nf_conntrack           96202  6 nf_conntrack_ipv6,xt_NOTRACK,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ipv4,xt_conntrack
ip6table_filter        12815  1 
powernow_k8            29481  0 
ip6_tables             27864  4 ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
fuse                   87950  3 
af_packet              35338  2 
x_tables               34102  16 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,xt_NOTRACK,ipt_REJECT,iptable_raw,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
vmblock                22807  1 
mperf                  12667  1 powernow_k8
microcode              35758  0 
dm_mod                 92333  0 
snd_hda_codec_idt      74966  1 
arc4                   12529  2 
hp_wmi                 13996  0 
sparse_keymap          13890  1 hp_wmi
snd_hda_intel          33441  1 
rt2800pci              18715  0 
rt2800lib              54408  1 rt2800pci
snd_hda_codec         118874  2 snd_hda_codec_idt,snd_hda_intel
crc_ccitt              12667  1 rt2800lib
rt2x00pci              14577  1 rt2800pci
rt2x00lib              54582  3 rt2800pci,rt2800lib,rt2x00pci
mac80211              332546  3 rt2800lib,rt2x00pci,rt2x00lib
snd_hwdep              13613  1 snd_hda_codec
snd_pcm               109594  2 snd_hda_intel,snd_hda_codec
uvcvideo               76804  0 
snd_timer              34086  1 snd_pcm
snd                    86602  8 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
videodev              102250  1 uvcvideo
soundcore              15091  1 snd
ums_realtek            13317  0 
sp5100_tco             13791  0 
fglrx                3137930  100 
ecb                    12863  1 
v4l2_compat_ioctl32    17083  1 videodev
btusb                  23904  2 
uas                    18027  0 
bluetooth             270903  23 rfcomm,bnep,btusb
joydev                 17606  0 
pcspkr                 12702  0 
k10temp                13166  0 
snd_page_alloc         18572  2 snd_hda_intel,snd_pcm
i2c_piix4              13828  0 
sg                     36561  0 
battery                18608  0 
hp_accel               21880  0 
lis3lv02d              19968  1 hp_accel
wmi                    19256  1 hp_wmi
input_polldev          13896  1 lis3lv02d
cfg80211              210325  2 rt2x00lib,mac80211
video                  19653  0 
ac                     13055  0 
r8169                  61333  0 
rfkill                 25967  5 hp_wmi,bluetooth,cfg80211
eeprom_93cx6           12725  1 rt2800pci
button                 13949  1 fglrx
autofs4                43290  2 
thermal                22961  0 
processor              45192  3 powernow_k8
thermal_sys            25017  3 video,thermal,processor

i see nothing about usb-storage or scsi or scsi-luns so perhaps it could be that. since i was told that might need enabled under mint, which was a different case, perhaps i should check if this kernel build has scsi_luns support or open a new topic about that.

The kernel is whatever is default for 12.1/Gnome 3/x64:

3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux

So I figured out how to check for LUN’s and it is there:

zcat /proc/config.gz | grep CONFIG_SCSI_MULTI_LUN


so i’m guessing it isn’t that.

I also noticed something about sr_mod and how it isn’t listed when I run lsmod

Could sr_mod or usb-core matter at all?

modprobe -l reports kernel/drivers/scsi/sr_mod.ko

Would that mean sr_mod is installed, and perhaps it just isn’t loaded?

do these sections mean anything?

/usr/src/linux-3.1.0-1.2-obj/x86_64/desktop #cat .config

# MMC/SD/SDIO Card Drivers

# MMC/SD/SDIO Host Controller Drivers

OK. While I feel like an idiot, and very bad for having wasted anyone’s time who may have been trying to solve this; it is in fact solved.

I have no idea or how, all I can say is:

I got sick and tired of not understanding why everything appears as it should, so I pulled out 7 different micro sd to sd readers, as I don’t HAVE an actual sd card, and started trying all of them in Mint. What I discovered was they seemed to be working sometimes and not at others.

Well who would know but I also rotated between MicroSD cards in the process, and not realizing at all until the end: It turns out the card I use the most for testing, but never actually use in my phone, is damaged. It has what looks like a small hairline razor cut in one side, and you can clearly see it gashing right through a line. The problem became obvious.

I took the working sd to micro sd reader and put the working card in it, tested it in mint one last time and rebooted, and wouldn’t ya know it just works.

Well, at least I can stop bumping this, and perhaps SOMETHING in the mess is useful to someone.

Cheers! /slaps-self-senseless