HP all-in-one WLAN scan & print works fine, on one machine only

HP Photosmart 7520 all-in-one printer works fine over WLAN when used from one openSUSE 12.2 laptop, but just prints ASCII gibberish when used from another laptop running openSUSE 12.2 in the same network. I have no clue where the difference could be, so thanks for any suggestions how to proceed!

Minor problems that I solved thus far (this hopefully helps others):

  • The 7520 requires hplip version 3.12.9 or higher, but openSUSE 12.2 comes only with 3.12.4, so I installed 3.12.10a from obs://build.opensuse.org/Printing on both machines through 1-Click from the openSUSE getit webpages.
  • Scanning & Printing over WLAN only works if the client’s firewall allows Zeroconf/Bonjour.

(BTW: I do not understand at all why I need to open a port on my laptop just to print?! Neither installation, HP Toolbox, nor printing/scanning works unless I add Zeroconf/Bonjour to Yast->Firewall->AllowedServices for the demilitarized zone, where my WLAN interface now belongs to. Can anyone shed light on that?)

I have two laptops Dell M4400 and M4500, both got a fresh install of 12.2 a few weeks ago (just the home directories were preserved), one a couple of days later than the other. I believe I did the same steps on both, same repositories. One of them prints & scans just fine over WLAN. The other one, the M4400, always prints ASCII gibberish only.

The crazy thing is that the M4400 printing ASCII gibberish otherwise talks fine to the Photosmart: the HP Toolbox correctly identifies the device, show the correct status infos and ink levels.

Even more weird, it also prints ASCII gibberish over a direct USB connection, while scanning works perfectly fine out of the box over USB at the same time. (Also note: scanning does not work over WLAN on the M4400, but it does on the M4500.)

I am really at a loss how to proceed here. I cannot recall what I did differently on either machine, except that the first print attempt on the M4400 was done with LibreOffice, which asked for root permissions to install some kind of plugin (it did not say which one), which we allowed. On the M4500, LibreOffice just printed right away, without asking for permission to install a plugin. I also tried a fresh account on M4400, but it also just prints ASCII gibberish. Note that the M4400 prints fine when running Windows, so it is likely to be a software fault.

PS: Of course, I since tried to print from other applications, such as Okular, after a fresh reboot, without starting LibreOffice before, but from the M4400, the Photosmart 7520 still just prints gibberish, no matter what kind of document I try.

It reads to me like you’ve configured a different driver on each of the respective machines. I would check that the ppd files in /etc/cups/ppd are the same.

Does ‘hp-testpage’ succeed with your Dell M4400?

Thank you so much! That saved me from madness!

Sure enough, the ppd files differed: the one on the working machine read hpcups while the one on the other machine that did not work read hpijs. I just copied the file from the working machine to the other, rebooted just to be sure, and it work fine now - even scanning over WLAN. Yay!

(BTW, no the hp-testpage had also only produced gibberish on the non-working machine.)

Thank you so much! That saved me from madness!

Glad to be of help! :slight_smile:

(BTW, no the hp-testpage had also only produced gibberish on the non-working machine.)

Yes, that would have failed until you had the working ppd installed.

I just installed a new HP Photosmart 7520 with Wireless access and indeed I found that the hpijs file did not work properly. With the hpijs I got just a few charaters per page, sending out several pages for a one page print which I had to cancel to stop killing trees. Switching to a second file without the hpijs name in it and everything started printing just fine. I don’t know what is wrong, but since the other file works just fine I guess I don’t care.

Thank You,