HP all-in-one Deskjet F4280

I think i do something wrong, the printer is found but dusn’d print a test page.
I have installed the HP all-in-one in software management, i think that a have no root rights, is that possible and how to fix it.
Artfreddy :frowning:

This is not much information for someone to help you.
What SuSE version, KDE/Gnome, what does YaST > Hardware > Printer say about that printer, what did you do, more???

Gnome 11.0… Yast find as printer F4100 series but the correct printer is not in the database, i dont think thats the problem ???
What i did…
In Yast : Add new printer…
There i found the F4100 series but i cant not configure the printer, more than that i dont now, new hey !
What i see in the database that when i look in HP, the correct all-in-one is not there, only HP F4100 series. I dont now if thats the problem.
Thanks for Your answer, and have a nice evening, :wink:

Well, I have an F4180 and it is also seen as F4100 by YaST.

Do you have hplip installed?

Also read this other thread: Hp psc 950 - openSUSE Forums

CUPS can be reached at: http://localhost:631/

When CUPS is not runing goto YaST > System > System Services (Runlevel), look for cups, selecty, click Enable and Finish.

Thanks for Your answer. hplip is installed, but gonna do what You say, because i dont believe that CUPS is installed.
Everything comes good, with a little pattience.
Thnaks for the help. :wink:

I do have a HP Deskjet F4180.
It run well with openSUSE 11.0 with Gnome-environment.
Last night I installed openSUSE 11.1 using Gnome again.
The printer is recognised and the test page prints,
but I cannot print from an applikation - evince for example.
The HPLIP Status Service is present in the panel and I can open it,
see the printer and settings, cups is installed and running.
Where is the trick?


I have the print function of the All-In-One-Deskjet F4280 working on my mother’s openSUSE-11.1 PC.

But I do not have the scan function working yet. I’m still scratching my head on this, but I have not yet spent much time looking at it (I’ve spent about 10 minutes thus far on this (less time than it has taken me to type this reply)). I’m hoping later this week I’ll get it sorted.

OK, I have the scan function working for the HP All-in-One Deskjet F4280 under openSUSE-11.1 on my mother’s PC.

It turns out this was a permissions problem in openSUSE-11.1. By adding the regular users to group “lp” I was able to scan successfully with kooka under KDE-3.5.10 on openSUSE-11.1.

I am using the generic “hpaio” scanner driver (setup under YaST). I also have the Packman hplip installed (hplip-hpijs-packman and hplip-packman-2.8.10-2.pm.4.i586.rpm) on my mother’s PC.

But sorting the permissions was the “tricky” part. I found that by a quick surf, stumbling on this post: SourceForge.net: HP Linux Imaging and Printing: hplip-help

Any news on this subject?
I upgraded to OpenSUSE11.1 with Gnome-Desktop again, because of some issues with Mozilla-related programs recently.
I installed my HP Deskjet F4180 easily, but it still wont print more than the test page.
The device is displayed, the status of the ink-cartridges is correct, I can scan successfully with xsane.
I tried to install the printer using YaST as well as HP-Setup in a terminal.
Everything seems fine to me, but I cannot print from an application.
Every hint welcome, Dickfell

did you try adding the regular users to group “lp”. Note you should restart after making that change.

I wonder if this is a gnome problem?

My mother is using kde-3.5.10, and where possible, I changed her applications to print to “kprinter” which handles her printing nicely (where her printer is the F4280). She is 83 years old, and the printer works well for her.

You may need to be more specific as to what print command your gnome applications are using. I’m not a gnome user, so I can NOT help. All I can say is it “just works” under KDE-3.5.10.

From yast, remove your printer.
Install the hplip package (Latest version is available on packman).
Run hp-check to see the completeness. (All options may not be required).
Switch on the printer and from konsole/GUI terminal, run hp-setup. This will configure your printer.
From the desktop menu, run the “HP Printer Control” (or a similarly named program - just search for HP). This will stay in SystemTray and good for viewing printer status.
With this, you get all features of the printer, including scanning.

@oldcpu: I read your post earlier & added myself (regular user) to the group >lp< & I rebooted as well.

@syampillai: I did as suggested, but the result is still the same. I ran hp-check & solved all the dependencies. I ran hp-setup & the test page printed well.
But printing from an application like evince doesn’t work at all. The system takes several minutes to spool & prints just some incomplete characters instead of the page of text I intented to print.

Any more/other suggestions?

If your test page was printed correctly, your printer driver set up is correct. Can you try from some other application first and verify?

out of interest: try and load CUPS:


you do that in the top line of your Firefox: it runs on your local system, and so no security issues; look in manage printers: see what is there; some may suggest deleting the existing entry, and starting afresh; I have not struggled with hp and can’t really comment

Thanks to all helping voices.

@pdc_2: I have had no issues with my HP F4180 using openSUSE11.0,
the upgrade to 11.1 was the challenge.

I deleted all printers again & installed only the existing one = my HP F4180.
The test page printed well again & I tried to print from OpenOffice instead of Evince - & it worked!
So eventually my is setup correct, but PDF-readers - like Evince or XPDF won’t print.
What could be the cause for this?

nice Conversation it would really helpful for the people who are facing the same problem. I already through this problem in past and at that time I contact the customer support center. they solve my problem without any charge.

Inkjet Cartridges