hp 8440p notebook and Arrandale video problem (but not in failsafe)

I have a problem during installation of openSuse 11.3 on my brand new notebook.
It’s an hp8440p with Arrandale integrated graphic controller. The initial install works then as soon as the notebook reboots to complete the install and allow me to log in for the first time, there’s no video. If I shut the notebook down and boot into failsafe mode the video works. I shut down again and come back up as a normal boot and no video again.

Any ideas?

And what’s the difference between normal and failsafe?
I ran glxgears and had 3d accel in failsafe…

When you startup openSUSE and you are still in the Grub menu selection, you can type in the command nomodeset for the standard openSUSE kernel load and then press enter. This is one of the commands in the failsafe line and may be the one that lets you run. If it does, you can edit the /boot/grub/menu.lst file as root to add the nomodeset command option as a permanent startup command.

Thank You,

And put that command where?
Here’s the section from my .lst file

title openSUSE 11.3 - 2.6.34-12
root (hd0,1)
kernel /boot/vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-ST9250410AS_5VG6G0Z1-part2 resume=/dev/disk/by-id/ata-ST9250410AS_5VG6G0Z1-part1 splash=silent quiet showopts vga=0x361
initrd /boot/initrd-2.6.34-12-default

I booted normal using nomodeset and everything appeared OK until I went to configure the desktop and I couldn’t enable desktop effects or preview a screensaver animation. errored out when I clicked apply. The dialog said to check X configuration.

So does this laptop have dual video systems (I saw one that had ATI and Intel) or is it just Intel only? Basically, we need to find the right video driver for your video chipset and the default does not seem to be working for you. If it has say an ATI video setup in addition to Intel, one could switch to ATI and load the proprietary ATI driver where you could get 3D support.

Thank You,

this is what hp says on line:
Graphics NVIDIA NVS 3100 graphics with 512 MB dedicated gDDR3 video memory
Intel® HD Graphics
Microsoft DirectX 10.1 (Shader Model 4.1) capable
Microsoft DirectX 10 (Shader Model 4.0) capable

openSuse only shows me intel Arrandale.

I guess I should try installing the nvidia driver from failsafe and try again. Not sure how to switch from one to the other though.

So consider that I do not understand the graphic system in your laptop, however if you use or can switch to nVidia, here is what I would do to load the proprietary video driver.

For openSUSE 11.3 installs you need to read the following document:

SDB:Configuring graphics cards - openSUSE

Next, I have the procedure I used to add the nVidia driver during the installation of openSUSE 11.3 which might also be useful.

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.35.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Please let us know if this was helpful or not.

Thank You,

When I begin to install openSuse 11.3 I can see my display. There’s a point in the install where the notebook reboots and then the install completes and you normally end up at a login prompt.

As soon as MY notebook reboots I have no video and can’t witness installation completion. I have to depress my notebook power switch to shut down. From here I can restart and get to the grub menu. And I can boot normal with nomodeset in the area to enter text or I can boot in failsafe mode where I have video for either.

Is there any way to override the installs pick of a video driver before the install reboots?
The first time I tried this it looked like everything was OK until I tried my wirelss LAN and that didn’t work. After numerous posts I hoped my install was bad tried reinstalling with auto login enabled and now my wireless works.

My work around was to enable auto login for the install. That way at least I got a complete install.

There’s GOT TO BE a better way.

This is a very new notebook: elitebook 8440p.

I tried 11.2 and lost video even sooner.

So mikeinsantarosa, you have got to read back through my post on installing the nVidia video driver. If, when you install openSUSE 11.3 and your PC reboots for the first time and you can not see any video, then you must turn off and restart your PC again. Then, when you see the grub OS selection menu, select the normal kernel load for openSUSE, but type in the option nomodeset and press enter. To make this one command permanent after you get openSUSE to start a normal session after the installation, then enter this command if you installed KDE as your desktop, menu Run Command:

kdese kwrite /boot/grub/menu.lst

Add the nomodeset command to the normal kernel load line at the end. Here is what my one line looks like after adding in nomodeset:

    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Maxtor_7H500F0_H81AGJDH-part2 resume=/dev/disk/by-id/ata-Maxtor_7H500F0_H81AGJDH-part1 splash=silent quiet nomodeset showopts vga=0x346

Now you are trying to add in just this one command which will be among many. Once this is done, save the file. Once you have done that you can restart your PC as often as you like and you will get a picture. However, you need to do more to download and install the nVidia video driver.

Thank You,

actually this version of notebook doesn’t have nvidia graphics, it has intel.
The first time I installed 11.3 I don’t think it was completed correctly. A second install fixed it but the trick was to enable aut login so the install would complete.

So you don’t actually have nVidia on board, you decided to reinstall openSUSE 11.3 and after selecting the auto login option everything installed/worked just fine. Well it is hard to argue with success and I am very happy that you got your laptop up and running. I hope I did not lead you astray during your installation ordeal.

Thank You,

Yup I added the nomodeset to grub and that all works.

Now I’m missing sax2 - trying to fix my graphics

Does that come with 11.3?

Sax2 was removed in openSUSE 11.3 as it only provided access to standard drivers and was not much help with binary drivers that everyone seems to load. None the less, it was something to fall back on, but it is no longer there.

Thank You,

You were given the URL : SDB:Configuring graphics cards - openSUSE above in a post. That CLEARLY states there is no sax2 in openSUSE-11.3.

That suggests to me you did NOT bother to read that guide. I recommend you go back and READ that guide. Else you are wasting your time , because our assumption is that you have read that, and now we can not tell what you have read, and what you have not read.

Please make it easier for us to help! Good luck !