HP 840 No Sound XFCE

I am running LEAP 42.2 on an HP 840 clean install and I have no sound. If I go through the Yast sound module and run through the wizard I get the test sound to work but nothing else. I also am constantly getting the Audio Mixer panel stopping and I am presented with the Execute to restart it. When I was running LEAP 42.1 this worked on this notebook. I then switched to Fedora 25 and things just worked. I was hearing good things about Tumbleweed but unfortunately for this hardware I had nothing but problems so I went back to LEAP 42.2. I thought everything was working until I need to hear a video and discovered I had no sound.


I am not sure what else to do. The touchpad on this is very touchy and wasn’t with Fedora 25 and I was running XFCE on Fedora as well. That is a different issue and one that takes a backseat to my sound issue.

Did you install the required multimedia codecs from the Packman repo yet?

No what are the required codecs I need to install?

Here you go…

I installed everything according to this site but still don’t have any audio.

Some additional information:
speaker-test -c2 -l5 -twav

speaker-test 1.1.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_dmix.c:1098:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.4.62-18.6-default.

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

cat /proc/asound/cards
0 [HDMI ]: HDA-Intel - HDA Intel HDMI
HDA Intel HDMI at 0xd0730000 irq 53
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xd0734000 irq 52

I followed this - https://en.opensuse.org/SDB:Pulseaudio and once PulseAudio was installed I now have sound. I know previously with 42.1 my notebook function keys also worked to control the volume but I’m just happy to have sound. Crossing my fingers 42.3 fixes all of this when it is finally released. I have no idea why it would work and then not work in 42.2.

I’ll continue to work on this and if it gets to be too big of a pain I can always go back to Fedora. The beauty of OSS.