HP 6735s 64 bit audio problem

HP 6735s AMD x2 64 bit - SuSE 11.1 with updates and patches as of 8/29/09

I have done the following and am real confused as what to do???
No sound with speaker test even though there was a print out.

Need some direction, this is my first at 64 bit.

Thanks,
Jack

http://www.alsa-project.org/db/?f=675300a52ee1244a1c46bca59e1cc116dd547af6
speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
 0 - Front Left
 1 - Front Right
Time per period = 2.685138

OK, I note an AD1984 from the script. When I do a search on the alsa web site for the AD1984 I note the following, suggesting there was an update after the 1.0.17/1.0.18 version of alsa that you have installed with openSUSE-11.1:
Search results for AD1984 - AlsaProject

But before applying an update, lets see if we can get it to work as it is. Add the following line to start of the /etc/modprobe.d/sound file, save the change, reboot and test your sound:

options snd-hda-intel model=laptop

Reference: HP-Compaq 6735S [Linux Laptop Wiki]

First let me say you are very goooood, have listened to you over the years and because of you Linux is great for me.

OK, I have sound after adding that line to /etc/modprobe.d/sound

I have system sound in KDE and audio in firefox video playback. I don’t have mic in Skype, which by the way got to run in 64 bit, thanks to Skype HOWTO - openSUSE

Now the sound in with mic. Skype insists on pulseaudio and have a bunch of 32 bit stuff from Skype HOWTO - openSUSE

What should I be looking at now?

Jack

Super. Congratulations !! Thank you for sharing your solution ( mental note - the openSUSE HCL for HP needs to be updated to reflect this: HCL/Laptops/HP - openSUSE )

I do not use Skype, so I can not help you with that application.

But IMHO before you waste your time with Skype or any other application, you should first ensure basic mic functionality is present.

Take a look here (ok that page needs work - I updated it a bit but it is still lacking): Microphone setup - openSUSE

ie from that URL, use this command for testing your mic (talk into your mic):

arecord -vv -fdat foo.wav 

where “foo.wav” is a file that you will create (it does not have to be called “foo.wav”, call it “bob.wav” or anything … ). Press to abort. Then play it back and see if you can hear sound. Note the mic levels indicated with that command. Play with your mixer settings to try and get a better quality recording.

If no success, can you also provide your mixer settings? With your PC connected to the internet, and with your mixer setup the best way (the BEST WAY) you think it should be set, copy and paste into a terminal/konsole:

amixer > amixer.txt && curl -F file=@amixer.txt nopaste.com/a

that will paste your mixer settings to the web and give you a URL. Post here the URL and I will comment on your mixer setting. Note in KDE4 mixer under channel you can add more controls to your mixer.

The arecord froze and the wav, ???
Here is the amixer.


Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 1638 [2%] [on]
Front Right: Capture 1638 [2%] [on]


After et’al and a re-boot I had mike control in Kmix - I very tired and will have to nail it all down later.

From everything I’ve read about this laptop and SuSE it should all work. Just a lot of I’m new to 64 bit and libs.

Later,
Jack

Thanks. Please, I really want to see the ENTIRE amixer output, … not just the bit you choose to give me. Please don’t be insulted, but its possible you missed something, so its better to just give the URL or the entire amixer output like I asked. Also note, in what you gave me, 2% capture is WAY too low. Push it up to 90%, establish your recording, then lower the level to improve quality.

If you the curl command did not work, then just run “amixer > amixer.txt” and post the content of amixer to a pastebin site such as: pastebin - Type, paste, share. and provide me the URL.

I do not know that this means. Does it mean it finally works in arecord? … Note arecord should NOT freeze.

Note there is still more that can be done. We did not try for an alsa update, and if worst comes to worst, and if the quirk noted in my AD1984 search on alsa is impacting your mic, we can always go for an alsa update (I can explain how to do that if necessary).

Hey good morning,
Was just going to ask about ‘how’ for alsa update. I’ll try the other commands again.
Jack

Hi,

arecord worked fine this time, even read the man pages :slight_smile:

amixer

http://nopaste.com/p/aLwaR4w7qb

Now I’m ready to do Skype again with some knowledge under me.

Should the alsa have that patch? How?

Jack

Great! So your mic is working, and any other problems you may have are application specific.

ok … I confess that HAS to be the shortest amixer output I have every seen.

Was that all ?? Or did you trim it?

For example, the one on my PC yields this: amixer.txt - nopaste.com (beta)

If arecord works, then there is no need to update alsa. You could simply end up breaking things inadvertenly. My view is “if it ain’t broke, don’t fix it” :slight_smile:

But since I did mention it, the guidance for updating the alsa user space is here. Alsa-update - openSUSE … Also note the link toward the bottom of the page where in addition to updating the alsa user space, one can also update to daily snapshot versions. Alsa-update-snapshot - openSUSE … My advice is still not to “fix it” if it arecord works. This is likely a Skype configuration problem.

BUT if that was ALL you get for amixer, then there is a problem with your sound, and you probably should update alsa to 1.0.20. …

In which case, please advise and I can point out specific commands from the URL I gave (although I think the guidance in those URLs should be clear - in each case there are 6 zypper commands that should be sent).