HP 6730b LapTop

I installed Suse Linux 11.2 (the best of all Suse Linux up to now)
Most features work fine with the HP6030b. But there are two issues that occure often and are bugging me. I do not know, but they might be related, so I mention them in the same post.

Problem 1)

Back-light mostly works fine: I can change the amount of back light via the power-management (moving the ruler with the mouse) :); though it cannot be adjusted via the fn-key :frowning: (I can live with that bug)

  • sometimes, however, I log in after a restart of the lap top, and the back-light sets to dark (minimum back-light). Trying to increase it via the power management does not work. Only after a restart, it might work again as usual.
  • I guess it has something to do with the start up procedure, that either a service does not succeed starting… But what can I do, to improve that behavior?

Problem 2)

Normally screen resolution is fine, but sometimes it does not set to the proper resolution after a boot or after a logout.

  • Case 1: I boot the lap top. When the log-in screen appears, it displays to the lowest resolution, after log-in, I have to set back to the standard resolution explicitly

  • Case 2: I boot the lap top. When the log-in screen appears, it displays to the lowest resolution. After a reboot it sets back to the proper resolution

  • Case 3: I boot the lap top, and the log-in screen displays properly. I log in, and afterwards a may log out or change to the log-in screen to log-in as an other user. The log-in screen now displays at a low resolution - even so the new logged in user displays at the low resolution

The problem of the low resolution seams to appear randomly - I was not able to make out a pattern

I used to have problem #1 as well, since the update to KDE 4.3.5 it seems to be solved though.

And occasionally I see problem #2 come by as well. I usually fix it for the time being by switching runlevel down to 3 and up to 5 again. This happened on this 6730b in 11.1 under Gnome as well by the way.

Regarding problem 2 it may be related to X not using a xorg.conf file by default anymore, but relying in auto-detection. When you log out and in again you are changing X modes, and for some reason X doesn’t detect your current configuration anymore - a bug in X related to your specific hardware, defective EDID info from your monitor, etc).

As a workaround you may try creating a xorg.conf file using sax2, if this file exists X will use it. Before that you should check out /var/log/Xorg.0.log after an ocurrence, you may find out what the problem is.

And do keep updating, it may take some time but will eventually fix the problem.

Thanks for the infos. I’m using KDE 4.3.5 release 3, so I think, that problem #1 is still there on this version.


Does someone have a answer to Problem #1?

Regarding Problem #2, I’ll try the suggested work-around

I tryed suggested workaround for problem #2. The result: The lap top still logs in sometimes with wrong resolution, though its not the lowest anymore, but a higher resolution, than set throug the sax2 configuration

Are there still no suggestions for problem #1?

About first problem:
Can you show content of /sys/class/backlight/acpi_video0/ directory if it exits.

ls /sys/class/backlight/acpi_video0/

Also, can you show value of /sys/class/backlight/acpi_video0/max_brightness if it exits.

cat /sys/class/backlight/acpi_video0/max_brightness

i have KDE 4.3.5 installed, same problem, and i think there is workaround.

I have the same (Problem 1) on my daughters 6730b. I have tried some different solutions found on the net. I wonder how they solved this in SLED? I mean the Laptop was sold with SLED installed to company’s.

Running 11.2 -KDE4.42 on the Laptop.

This workaround, that works for me:

  1. Create script,which will set brightness through powerdevil’s dbus interface. For example, ~/bin/backlight.sh. Make him executable.
  2. Grab brightness hotkey keycodes with xev program and bind them to script with xbindkeys program. Or create new actions throught KDE System Settings - Actions.
# this script take one argument - {up|down}

# if you have other - change it
# maximum brightness value in percent
# minimum brightness value
# actually only 10 percent step make effect for me
# take value of current brightness in percent i believe

case "$1" in
up   )   BRIGHT=$(($BRIGHT+$STEP))     # if parameter is "up"-increase bright 
         if  $BRIGHT -gt $MAXBRIGHT ] # brightness can't be greater than 100%
	 then			       # but without this check works too...	
down )   BRIGHT=$(($BRIGHT-$STEP))     # if parameter is "down"-decrease bright
	 if  $BRIGHT -lt $MINBRIGHT ] # brightness can't be less than 0
	 then			       # but without this check works too...

*   )    echo $"Usage: $0 {up|down}"
	 exit 1
# set brightness through dbus
# qdbus is much simpler than dbus-send...
qdbus org.kde.powerdevil /modules/powerdevil org.kde.PowerDevil.setBrightness $BRIGHT

This script takes parameter up to increase brightness or down to deсrease brightness.

:wink: Thank you for your post

But how do I use xev to bind it to a key?

— and how do I use “create new actions throught KDE System Settings - Actions”?

Could someone give me precise instructions?



About Problem #2

The Problem is quite cumbersome.

This is how it shows up now, after having used sax to define the proper resolution (see suggestion to this problem above):

A) Case proper start up with proper resolution: I log in, and the resolution is fine. Then I want to log in as a second user. Now the session administration shows the users in a smaller font (or higher resolution). When logging in now, the screen shows smaller fonts(or higher resolution). Since the screen is not made for this resolution, it may leed to problems during the session.

B) It appears to be fully random when the case of the “high” resolution happens. Sometimes it happens at start up, sometimes logging in as a second, third … user, sometimes after logout and login again …

Maybe someone can tell me, where to look at, to give you more informations about the case



First, be sure that script works for you:

  1. Create script, which will set brightness through powerdevil’s dbus interface. For example, ~/bin/backlight.sh. Make this script executable.
  2. Set brightness to minimum, moving the ruler with the mouse.
  3. Call script with parameter up several times
~/bin/backlight.sh up

If script works, then open KDE systemsettings (Configure Desktop in K menu), in “General” tab, section “Computer Administration” seach for “Input Actions” icon. Click it.
In “Input Actions - System Settings” window click “Edit” - “New” - “Global Shortcut” - “Command/URL”. Input name for the action, for example, brightup. In “Action” tab, input command with full path and parameter up.

~/bin/backlight.sh up

In “Trigger” tab input shortcut for action. I couldn’t assing native shortcut Fn+… with KDE, but any other free shortcuts works well. I did use META+…
Do same sequence for brighdown action, exept parameter of the script should be down.

About Problem #2:

Thanks a lot for the instructions. I followed them, and am now able to set the backlight by a key combination.

Now I wonder if it works also in those cases, where the rulers of the power management don’t.

I’ll let you know by the next occasion



Interesting to know, thanks.
I believe that this method will not function without working powermanager.

About problem with wrong display resolution:
Try the following:
1 If you have xorg.conf file, remove it.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.back

2 Reboot laptop.
3 After login, if you have proper display resolution, find out mode settings for your display:

cat /var/log/Xorg.0.log | grep -i modeline

also, check your current resolution:

xdpyinfo | grep resolution

4 Open to edit /etc/sysconfig/displaymanager file.
Change DISPLAYMANAGER_RANDR_MODE_auto variable with modeline from your Xorg.0.log file (see step #3). For example:

DISPLAYMANAGER_RANDR_MODE_auto="1280x800_60 69.30 1280 1296 1344 1416 800 801 804 816 -HSync -Vsync"

Change DISPLAYMANAGER_KDM_LOCALARGS variable value. Add -dpi option to kdm. For example:


5 Open KDE systemsettings, in “General” tab - “Appearance” - “Fonts” - set “Force fonts DPI” as “disabled”. Apply settings.
6 Reboot laptop (relogin will not work)
7 Check current display mode:


and resolution:

xdpyinfo | grep resolution

Hope it will help.
Best regards.

:slight_smile: Hallo

Thanks a lot for your precise instructions regarding problem #2. I followed the instructions, and up to now, it seams to work - if the error should show up again, I’ll let you now. First test, however are positive.

Thank you, and wish you a nice week end.

Diete Ernst


I’m back again, with some of the problems mentioned:

About Problem #1:

  • The script for the keys works fine, when the back light sliders of the power manager work.
  • Sometimes the sliders don’t work; when that happens, also the script does not.

About Problem #2:

  • After following the instruction of novsan. First it seamed solved. But every once in a while the old problem showed up again. The login screen would show in a very low resolution, and after login, the KDE desktop too.

  • Since it happened often, I tried to set the resolution via xas2. The result being, that now the resolution would show to high every once in a while.

  • It seams to be a HP6730b specific problem, since that does not happen to my son’s laptop (which is not HP)

Maybe someone has more ideas, on how to find a solution to the problem - maybe even a final solution to include in the next release of Suse Linux.

Thanks a lot


about problem #1:
Script sets brightness using KDE powermanager. So, if KDE powermanager fails, script doesn’t work.
problem #2
Hope that the next version of openSUSE will contain KMS for intel videocards enabled by default.
Best regards.

Continue :slight_smile:
About problem #1
Try to add acpi_backlight=video and acpi_osi=Linux (or vice versa acpi_osi=!Linux) parameters to the kernel.

About problem #2
Try this workaround:
1 Remove xorg.conf file
2 Clear value of DISPLAYMANAGER_RANDR_MODE_auto variable in /etc/sysconfig/displaymanager file


add -dpi option to DISPLAYMANAGER_KDM_LOCALARGS variable


3 Create script:

# put your display mode here
# put desired resolution here
xrandr -s $SCREEN_MODE
xrandr --dpi $SCREEN_DPI

Make script executable. Script will force set display resolution, if it wrong.
Copy script into ~/.kde4/Autostart/ directory for every kde user. Be sure that users have rights to execute script. Script will execute on every KDE start.
4 Reboot laptop.

Hope it helps.
Best regards.